Topics

"This Radio Is In Use" Msg. Can't Run Problem ?

rmrrgs
 

Hi,

Always something, I guess.

Using program with an SDR Play RSP 2.
Never any problems.

Now, whenever i try to start it, I get a msg. that says: This Radio is In Use.
The screen show up, and I can change the frequency digits.

I select the RSP-2 in the Select screen, and press Start.
Then the msg appears.

What might I, as usual, be doing wrong, or what might be the problem ?

Thanks,
Bob

Simon Brown
 

Hi,

 

Show me the message window please.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of rmrrgs
Sent: 07 November 2019 21:22
To: main@SDR-Radio.groups.io
Subject: [SDR-Radio] "This Radio Is In Use" Msg. Can't Run Problem ?

 

Hi,

Always something, I guess.

Using program with an SDR Play RSP 2.
Never any problems.

Now, whenever i try to start it, I get a msg. that says: This Radio is In Use.
The screen show up, and I can change the frequency digits.

I select the RSP-2 in the Select screen, and press Start.
Then the msg appears.

What might I, as usual, be doing wrong, or what might be the problem ?

Thanks,
Bob

rmrrgs
 

Hi,

Thanks for help.
Here's a screenshot:


On Nov 7, 2019, at 4:23 PM, Simon Brown <simon@...> wrote:

Hi,
 
Show me the message window please.
 
Simon Brown, G4ELI
 
From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of rmrrgs
Sent: 07 November 2019 21:22
To: main@SDR-Radio.groups.io
Subject: [SDR-Radio] "This Radio Is In Use" Msg. Can't Run Problem ?
 
Hi,

Always something, I guess.

Using program with an SDR Play RSP 2.
Never any problems. 
Now, whenever i try to start it, I get a msg. that says: This Radio is In Use.
The screen show up, and I can change the frequency digits.

I select the RSP-2 in the Select screen, and press Start.
Then the msg appears.

What might I, as usual, be doing wrong, or what might be the problem ?

Thanks,
Bob 


Simon Brown
 

Hi,

 

Thanks. Check for a Zombie process, failing that reboot the PC.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of rmrrgs
Sent: 07 November 2019 21:34
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] "This Radio Is In Use" Msg. Can't Run Problem ?

 

Hi,

 

Thanks for help.

Here's a screenshot:…

rmrrgs
 

Hi,

What's a "zombie process" please ?

Tried shutting down and re-starting.
No luck.
Same msg.

Thanks for time and help,
Bob
--------------------------------------------------------

On Nov 7, 2019, at 4:34 PM, rmrrgs <rgsrose@...> wrote:

Hi,

Thanks for help.
Here's a screenshot:

<Capture a.PNG>
On Nov 7, 2019, at 4:23 PM, Simon Brown <simon@...> wrote:

Hi,
 
Show me the message window please.
 
Simon Brown, G4ELI
 
From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of rmrrgs
Sent: 07 November 2019 21:22
To: main@SDR-Radio.groups.io
Subject: [SDR-Radio] "This Radio Is In Use" Msg. Can't Run Problem ?
 
Hi,

Always something, I guess.

Using program with an SDR Play RSP 2.
Never any problems. 
Now, whenever i try to start it, I get a msg. that says: This Radio is In Use.
The screen show up, and I can change the frequency digits.

I select the RSP-2 in the Select screen, and press Start.
Then the msg appears.

What might I, as usual, be doing wrong, or what might be the problem ?

Thanks,
Bob 



rmrrgs
 

Hi,

Like I just mentioned, the W10 pc reboot didn't work.

But, I then plugged the RSP-2 power cord in and out.
Now it works.

Just so i can learn, any idea what might have happened ?

It is very likely related to this, i think:

I had set up earlier in the day Google Chrome Remote Desktop.
With it i was able to see and control whatever is on my W10 pc from my iMac.
Works perfectly.

I disconnected the Google Chrome Remote Desktop, and exited Google Chrome. Went back to Firefox.

Perhaps, in some manner, it (Chrome) did not (also) "release" the RSP-2 ?

Thoughts ?

Bob
------------------------------

On Nov 7, 2019, at 4:22 PM, rmrrgs <rgsrose@...> wrote:

Hi,

Always something, I guess.

Using program with an SDR Play RSP 2.
Never any problems.

Now, whenever i try to start it, I get a msg. that says: This Radio is In Use.
The screen show up, and I can change the frequency digits.

I select the RSP-2 in the Select screen, and press Start.
Then the msg appears.

What might I, as usual, be doing wrong, or what might be the problem ?

Thanks,
Bob

John Aldridge
 

On 07-Nov-19 21:57, rmrrgs wrote:
Hi,
Like I just mentioned, the W10 pc reboot didn't work.
But, I then plugged the RSP-2 power cord in and out.
Now it works.
Just so i can learn, any idea what might have happened ?
AFAIR, when I was doing some programming of the RSP using the SDRplay API directly, this behaviour happened when my program didn't call the proper uninitialise (usually because it had crashed!)

I guess a program that you used with the RSP might have crashed or been forcibly terminated rather than closing normally?

John

Dennis Matzen
 

Bob, I have a RSPduo and run into this problem from time to time. For me it seems to be related to using remote desktop (RDP) and losing the remote session. When I reconnect SRD Console, which was running, has exited. Not sure it does so gracefully and leaves the RSPduo in some kind of connected state. Unplugging the USB cable and plugging back in will clear it up and allow Console to find radio again.

Could be your Chrome Remote Desktop did something similar. 

kb3cs
 

sounds like the RSP-2 was powered the whole time until you cycled the power on the RSP-2.
if that was the case, then nothing with the W10 PC had to do with the issue you experienced.
cycling the power on the RSP-2 restarted whatever PIC(s) or CPU(s) it has inside.

  - 1001001 -

On Thu, Nov 7, 2019 at 01:57 PM, rmrrgs wrote:
Hi,
 
Like I just mentioned, the W10 pc reboot didn't work.
 
But, I then plugged the RSP-2 power cord in and out.
Now it works.
 
[...]

Simon Brown
 

Ah – now there’s good thinking!

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of kb3cs
Sent: 08 November 2019 13:31
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] "This Radio Is In Use" Msg. Can't Run Problem ?

 

sounds like the RSP-2 was powered the whole time until you cycled the power on the RSP-2.
if that was the case, then nothing with the W10 PC had to do with the issue you experienced.
cycling the power on the RSP-2 restarted whatever PIC(s) or CPU(s) it has inside.

  - 1001001 -

On Thu, Nov 7, 2019 at 01:57 PM, rmrrgs wrote:

Hi,

 

Like I just mentioned, the W10 pc reboot didn't work.

 

But, I then plugged the RSP-2 power cord in and out.

Now it works.

 

[...]

Mike Bott
 
Edited

If I remember correctly, my ASUS motherboard has a setting that allows power to remain to the USB ports even when the PC is powered down.  Smart-Charging or something like that.

--
Mike


On 11/7/19 4:57 PM, rmrrgs wrote:
Hi,
 
Like I just mentioned, the W10 pc reboot didn't work.
 
But, I then plugged the RSP-2 power cord in and out.
Now it works.
 
Just so i can learn, any idea what might have happened ?
 
It is very likely related to this, i think:
 
I had set up earlier in the day Google Chrome Remote Desktop.
With it i was able to see and control whatever is on my W10 pc from my iMac.
Works perfectly.
 
I disconnected the Google Chrome Remote Desktop, and exited Google Chrome. Went back to Firefox.
 
Perhaps, in some manner, it (Chrome) did not (also) "release" the RSP-2 ?
 
Thoughts ?
 
Bob
------------------------------

On Nov 7, 2019, at 4:22 PM, rmrrgs <rgsrose@...> wrote:

Hi,

Always something, I guess.

Using program with an SDR Play RSP 2.
Never any problems.

Now, whenever i try to start it, I get a msg. that says: This Radio is In Use.
The screen show up, and I can change the frequency digits.

I select the RSP-2 in the Select screen, and press Start.
Then the msg appears.

What might I, as usual, be doing wrong, or what might be the problem ?

Thanks,
Bob