Topics

SRDPlay Instability Issues #sdrplay

Dennis Matzen
 

Just wanted everyone out there with a SDRPlay receiver hear about an issue I had. And how I fixed it.

The was having to unplug and reconnect the cable to my receiver (I have a RSPduo), restart SDR Console due to lockups and completely rebooting PC to get things working again. 

I thought this was a SDR Console problem as I had recently upgraded (I think it was from .9 to .10). But then I realized that I had also updated the SDRPlay software on the system.

So I started looking around and found in Windows "Programs and Features" that there were two versions of the SDRPlay API installed. I am sure this was my fault because when you install (or upgrade) the software they point out the receiver should not be connected to the PC until directed to do so. And I don't think I did that as I was not in front of the PC at the time (I was using remote desktop to do a upgrade).

So I uninstall not only the API software but all SDRPlay software, rebooted and reinstalled what I needed (following the directions this time).

System has been stable since. 

This was my own stupid error and I am sure no one else would do this. But thought I would share my story.

Fernando Gómez
 

Hi,

I have no problems for now with my RSP1A, but I have seen that I have installed two versions of API (2.13 and 3.02), and all the rest of the software too.

In addition, I also use the RSP-Spectrum Analyzer, and I am not sure which of the APIs you are using, since one of them is an improved version ... Would you know if I can remove the oldest one?

Thank you!!

 

Dennis Matzen
 

I ran into problem if I shutdown SDR Console and then ran Dump1090. Going back to SDR Console I would have various issues from not able to access the RSPduo to Console lockups.

I think your best option is to do what I did. Remove all SDRPlay software and then reinstall the latest versions. Like I said in my original post I think by not unplugging the RSPduo when I installed the updated versions was my problem.