Topics

SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13

Ian DXer
 

Hi Simon,

Here's a newly discovered software issue noted today that pertains to SDR Console v3.0.13 with my setup.

Fault Description: If I'm listening to a narrowband NFM transmission (eg 151.050MHz) Mode: NFM & stop the program (or not)
& tune to a BFM transmission eg 102.5MHz & switched decoder mode to BFM, the program visually responds correctly & I can alter the
spectrum bandwidth, but the decoded audio sounds as though stuck on a bandwidth 50kHz or like (but not NFM mode), it's like
listening to audio from matchbox sized radio or cheap smartphone.

No change of NFM, WFM or BFM modes or alteration of spectrum bandwidth filter or BW filters results in correct BFM mode decoding.
I have to close the program whilst the mode is set to BFM for correct FM BCB fidelity decoding upon restart of program.

Other notes:
Windows 7 64
SDR: Airspy HF+ DP (latest firmware)
SDR Console version: 3.0.13

jdow
 

Picture? (printscreen on keyboard if necessary. Use paint to edit out private stuff.)

{^_^}

On 20190907 19:12:44, Ian DXer wrote:
Hi Simon,
Here's a newly discovered software issue noted today that pertains to SDR Console v3.0.13 with my setup.
*Fault Description:* If I'm listening to a narrowband NFM transmission (eg 151.050MHz) Mode: NFM & stop the program (or not)
& tune to a BFM transmission eg 102.5MHz & switched decoder mode to BFM, the program visually responds correctly & I can alter the
spectrum bandwidth, but the decoded audio sounds as though stuck on a bandwidth 50kHz or like (but not NFM mode), it's like
listening to audio from matchbox sized radio or cheap smartphone.
No change of NFM, WFM or BFM modes or alteration of spectrum bandwidth filter or BW filters results in correct BFM mode decoding.
I have to close the program whilst the mode is set to BFM for correct FM BCB fidelity decoding upon restart of program.
*Other notes:*
Windows 7 64
SDR: Airspy HF+ DP (latest firmware)
SDR Console version: 3.0.13

Ian DXer
 

Hi Joanne,

I did think of posting a screenshot, but didn't think it would reveal anything useful in this case.
But your post got me thinking further about the 'Receiver' tab up in menu.
Under Mode field there is a NARROW FM button. I've just clicked & found that 'Highpass Filter' was ticked.
I've unchecked this & this has fixed the problem with receiving BFM for BCB FM signals :-)
Maybe I accidentally checked this last week when I was investigating something else?
A trap for the unwary :-)
Not sure if the program is intended to work like this or a bug, in any case I hope this post is helpful to someone.

Ian

Simon Brown
 

Ian,

 

Screenshots ALWAYS show useful info, without a screenshot I am flying blind. Please show a screenshot when BFM is not working properly. Make sure the Receive DSP panel is show. The NFM highpass filter should not be in the BFM processing chain.

 

Waiting for a screenshot please…

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Ian DXer
Sent: 08 September 2019 05:50
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13

 

Hi Joanne,

I did think of posting a screenshot, but didn't think it would reveal anything useful in this case.
But your post got me thinking further about the 'Receiver' tab up in menu.
Under Mode field there is a NARROW FM button. I've just clicked & found that 'Highpass Filter' was ticked.
I've unchecked this & this has fixed the problem with receiving BFM for BCB FM signals :-)
Maybe I accidentally checked this last week when I was investigating something else?
A trap for the unwary :-)
Not sure if the program is intended to work like this or a bug, in any case I hope this post is helpful to someone.

Ian

Simon Brown
 

Ian,

 

Did you have squelch enabled ? If so I found a bug.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Simon Brown via Groups.Io
Sent: 08 September 2019 13:41
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13

 

Ian,

 

Screenshots ALWAYS show useful info, without a screenshot I am flying blind. Please show a screenshot when BFM is not working properly. Make sure the Receive DSP panel is show. The NFM highpass filter should not be in the BFM processing chain.

 

Waiting for a screenshot please…

Ian DXer
 
Edited

Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH 'Stereo' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A &
'Highpass' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.
(LATE EDIT: NB. As previously mentioned must first be listening to a NFM transmission before switching
mode & frequency for reception of FM BCB station.)

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

Two edited screen shots attached.




Hope the above info & images help.
Please drop us a line if you need any further information.

Ian

Ian DXer
 

I'll try sending these images again (as attachments) after a cup of coffee this time...

jdow
 

They made it all three times.
{^_-}

On 20190908 19:06:45, Ian DXer wrote:
I'll try sending these images again (as attachments) after a cup of coffee this time...
BFM-Highpass-v3-0-13SH1J.jpg
BFM-Highpass-v3-0-13SH2J.jpg

Bill Walch
 

Here's a video (attached) that demonstrates this issue. Starting up v13, there's no problem switching between Stereo and Mono on BCFM. However, switching to NFM, then back to BCFM, when switching from Stereo to Mono, the sound goes "tinny", as though the bandwidth is being forced to a very narrow bandwidth in Mono mode. This also happens in v12.

Hope this helps,
Bill

On 9/8/2019 8:57 PM, Ian DXer wrote:
Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH 'Stereo' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A &
'Highpass' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

Two edited screen shots attached.




Hope the above info & images help.
Please drop us a line if you need any further information.

Ian

Bill Walch
 

Sorry, the sound on the last video didn't convert correctly. Hopefully this one works.

On 9/9/2019 3:02 AM, Bill Walch via Groups.Io wrote:
Here's a video (attached) that demonstrates this issue. Starting up v13, there's no problem switching between Stereo and Mono on BCFM. However, switching to NFM, then back to BCFM, when switching from Stereo to Mono, the sound goes "tinny", as though the bandwidth is being forced to a very narrow bandwidth in Mono mode. This also happens in v12.

Hope this helps,
Bill

On 9/8/2019 8:57 PM, Ian DXer wrote:
Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH 'Stereo' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A &
'Highpass' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

Two edited screen shots attached.




Hope the above info & images help.
Please drop us a line if you need any further information.

Ian

Attachments:


jdow
 

Just don't attach videos to the emails. They are too big for some people who get charged for each byte transferred, such as the poor souls using cellphones, for something Simon expressly does not want to see. It's impolite, particularly to do it twice.
{o.o}

On 20190909 00:11:19, Bill Walch wrote:
Sorry, the sound on the last video didn't convert correctly. Hopefully this one works.
On 9/9/2019 3:02 AM, Bill Walch via Groups.Io wrote:
Here's a video (attached) that demonstrates this issue. Starting up v13, there's no problem switching between Stereo and Mono on BCFM. However, switching to NFM, then back to BCFM, when switching from Stereo to Mono, the sound goes "tinny", as though the bandwidth is being forced to a very narrow bandwidth in Mono mode. This also happens in v12.

Hope this helps,
Bill

On 9/8/2019 8:57 PM, Ian DXer wrote:
Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH '*Stereo*' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A *&*
'*Highpass*' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

Two edited screen shots attached.




Hope the above info & images help.
Please drop us a line if you need any further information.

Ian
Attachments:

* BFM-Highpass-v3-0-13SH1J.jpg
<https://SDR-Radio.groups.io/g/main/attachment/49791/0>
* BFM-Highpass-v3-0-13SH2J.jpg
<https://SDR-Radio.groups.io/g/main/attachment/49791/1>
* Switching from NFM to BFM on v3.0.134-4.mp4
<https://SDR-Radio.groups.io/g/main/attachment/49791/2>

Bill Walch
 

Sorry, this is the first time I've heard that this type of problem documentation wasn't wanted. I've posted a few (linked) videos in the past, without issue. These were of coarse links to the videos that reside on the groups servers, not embedded attachments in the email to the group, so it would be optional to view them. The last email sent was only 9.7K in size. If your email client is downloading "attachment" content automatically, then you should look at changing this to an optional download. For this particular issue, I'd think that screenshots alone would not describe the problem, where only live video fully describes the steps to duplicate the problem, as well as the audio to hear the result of the problem. I'm sorry if this caused anyone problems.

On 9/9/2019 3:59 AM, jdow wrote:
Just don't attach videos to the emails. They are too big for some people who get charged for each byte transferred, such as the poor souls using cellphones, for something Simon expressly does not want to see. It's impolite, particularly to do it twice.
{o.o}

On 20190909 00:11:19, Bill Walch wrote:
Sorry, the sound on the last video didn't convert correctly. Hopefully this one works.

On 9/9/2019 3:02 AM, Bill Walch via Groups.Io wrote:
Here's a video (attached) that demonstrates this issue. Starting up v13, there's no problem switching between Stereo and Mono on BCFM. However, switching to NFM, then back to BCFM, when switching from Stereo to Mono, the sound goes "tinny", as though the bandwidth is being forced to a very narrow bandwidth in Mono mode. This also happens in v12.

Hope this helps,
Bill

On 9/8/2019 8:57 PM, Ian DXer wrote:
Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH '*Stereo*' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A *&*
'*Highpass*' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

Simon Brown
 

Bill,

 

Videos really are a PITA. A screenshot is the very best first step. As I wrote in another reply, I believe I have this problem fixed. Check whether you have FM Squelch enabled, if so disable it.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Bill Walch
Sent: 09 September 2019 18:02
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13

 

Sorry, this is the first time I've heard that this type of problem documentation wasn't wanted. I've posted a few (linked) videos in the past, without issue. These were of coarse links to the videos that reside on the groups servers, not embedded attachments in the email to the group, so it would be optional to view them. The last email sent was only 9.7K in size. If your email client is downloading "attachment" content automatically, then you should look at changing this to an optional download. For this particular issue, I'd think that screenshots alone would not describe the problem, where only live video fully describes the steps to duplicate the problem, as well as the audio to hear the result of the problem. I'm sorry if this caused anyone problems.

Bill Walch
 

Ok, thanks for the reply. I'm not trying to create problems, just offer some help. If a video is really the only way to describe a dynamic issue, what would suggest would be the best way to share that video? Some other hosting service like YouTube perhaps, although that may not be the best one? BTW, all squelch's were not enabled.

On 9/9/2019 1:22 PM, Simon Brown wrote:

Bill,

 

Videos really are a PITA. A screenshot is the very best first step. As I wrote in another reply, I believe I have this problem fixed. Check whether you have FM Squelch enabled, if so disable it.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Bill Walch
Sent: 09 September 2019 18:02
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13

 

Sorry, this is the first time I've heard that this type of problem documentation wasn't wanted. I've posted a few (linked) videos in the past, without issue. These were of coarse links to the videos that reside on the groups servers, not embedded attachments in the email to the group, so it would be optional to view them. The last email sent was only 9.7K in size. If your email client is downloading "attachment" content automatically, then you should look at changing this to an optional download. For this particular issue, I'd think that screenshots alone would not describe the problem, where only live video fully describes the steps to duplicate the problem, as well as the audio to hear the result of the problem. I'm sorry if this caused anyone problems.


jdow
 

Actually, I have the raw email. The audio files got included inline as base64. This is as received from the earthlink pop3s server direct with no web mail or anything else involved.

It didn't bother me except for the aesthetics of it. It does bother some other people. (I am on a landline DSL that makes molasses in January appear fast. It is unlimited, though, so the extra bytes cost me nothing more than storage space.)

{^_^}

On 20190909 10:02:18, Bill Walch wrote:
Sorry, this is the first time I've heard that this type of problem documentation wasn't wanted. I've posted a few (/linked/) videos in the past, without issue. These were of coarse _links_ to the videos that reside on the groups servers, _not_ embedded attachments in the email to the group, so it would be optional to view them. The last email sent was only 9.7K in size. If your email client is downloading "attachment" content automatically, then you should look at changing this to an optional download. For this particular issue, I'd think that screenshots alone would not describe the problem, where only live video fully describes the steps to duplicate the problem, as well as the audio to hear the result of the problem. I'm sorry if this caused anyone problems.
On 9/9/2019 3:59 AM, jdow wrote:
Just don't attach videos to the emails. They are too big for some people who get charged for each byte transferred, such as the poor souls using cellphones, for something Simon expressly does not want to see. It's impolite, particularly to do it twice.
{o.o}

On 20190909 00:11:19, Bill Walch wrote:
Sorry, the sound on the last video didn't convert correctly. Hopefully this one works.

On 9/9/2019 3:02 AM, Bill Walch via Groups.Io wrote:
Here's a video (attached) that demonstrates this issue. Starting up v13, there's no problem switching between Stereo and Mono on BCFM. However, switching to NFM, then back to BCFM, when switching from Stereo to Mono, the sound goes "tinny", as though the bandwidth is being forced to a very narrow bandwidth in Mono mode. This also happens in v12.

Hope this helps,
Bill

On 9/8/2019 8:57 PM, Ian DXer wrote:
Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH '*Stereo*' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A *&*
'*Highpass*' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

jdow
 

Regarding the video itself - I tend to agree with you; but, historically on this list Simon hates videos.
{o.o}

On 20190909 10:02:18, Bill Walch wrote:
Sorry, this is the first time I've heard that this type of problem documentation wasn't wanted. I've posted a few (/linked/) videos in the past, without issue. These were of coarse _links_ to the videos that reside on the groups servers, _not_ embedded attachments in the email to the group, so it would be optional to view them. The last email sent was only 9.7K in size. If your email client is downloading "attachment" content automatically, then you should look at changing this to an optional download. For this particular issue, I'd think that screenshots alone would not describe the problem, where only live video fully describes the steps to duplicate the problem, as well as the audio to hear the result of the problem. I'm sorry if this caused anyone problems.
On 9/9/2019 3:59 AM, jdow wrote:
Just don't attach videos to the emails. They are too big for some people who get charged for each byte transferred, such as the poor souls using cellphones, for something Simon expressly does not want to see. It's impolite, particularly to do it twice.
{o.o}

On 20190909 00:11:19, Bill Walch wrote:
Sorry, the sound on the last video didn't convert correctly. Hopefully this one works.

On 9/9/2019 3:02 AM, Bill Walch via Groups.Io wrote:
Here's a video (attached) that demonstrates this issue. Starting up v13, there's no problem switching between Stereo and Mono on BCFM. However, switching to NFM, then back to BCFM, when switching from Stereo to Mono, the sound goes "tinny", as though the bandwidth is being forced to a very narrow bandwidth in Mono mode. This also happens in v12.

Hope this helps,
Bill

On 9/8/2019 8:57 PM, Ian DXer wrote:
Hi Simon,

Thanks for the reply.
You had me pondering that there must be at least another variable involved in this bug condition.
After several minutes I found it.
If I have BOTH '*Stereo*' unchecked (i.e. MONO) in Broadcast FM; ref Image 1, label A *&*
'*Highpass*' Filter checked in Narrow FM; ref Image 2, label B, then when listening to a FM BCB
station in BFM mode the audio output HPF (audio) ("tinny" audio) condition occurs.

In my case Squelch is OFF. Ref Image 2.

Please let me know if you can emulate this condition now.
BTW Is the Highpass Filter checked in Narrow FM by default in v3.0.13? I may have checked it at some point, I simply
can't recall doing it.

Bote Man
 

Then I suggest that Simon is precluding himself from viewing evidence that might quickly lead him to a solution, whether it involves additional source code or a sentence or two of explanation here. These are offered in a spirit of cooperation and an effort to improve the software so that all might benefit.

(written as a former Luddite who has seen the error of his ways)


Bote Man
http://www.botecomm.com/bote/radio/streaming.html

-----Original Message-----
From: jdow
Sent: Monday, 09 September, 2019 15:20
Subject: Re: [SDR-Radio] SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13

Regarding the video itself - I tend to agree with you; but, historically on this list Simon hates videos.
{o.o}

On 20190909 10:02:18, Bill Walch wrote:
Sorry, this is the first time I've heard that this type of problem
documentation wasn't wanted. I've posted a few (/linked/) videos in the past, without issue.



--
Bote's Streaming Scanner Feeds
http://www.botecomm.com/bote/radio/streaming.html

jdow
 

The video demonstrates the symptoms. The pictures he wants tell him the state of the program. It is from the latter, perhaps with written "how I did it" descriptions, that he figures out the problem solution. The state of the radio is what is most critical. And videos tend to smear the data he is trying to read.

{^_^}

On 20190909 14:18:10, Bote Man wrote:
Then I suggest that Simon is precluding himself from viewing evidence that might quickly lead him to a solution, whether it involves additional source code or a sentence or two of explanation here. These are offered in a spirit of cooperation and an effort to improve the software so that all might benefit.
(written as a former Luddite who has seen the error of his ways)
Bote Man
http://www.botecomm.com/bote/radio/streaming.html
-----Original Message-----
From: jdow
Sent: Monday, 09 September, 2019 15:20
Subject: Re: [SDR-Radio] SDR Console Audio decoder mode stuck after switching from NFM to BFM on v3.0.13
Regarding the video itself - I tend to agree with you; but, historically on this list Simon hates videos.
{o.o}
On 20190909 10:02:18, Bill Walch wrote:
Sorry, this is the first time I've heard that this type of problem
documentation wasn't wanted. I've posted a few (/linked/) videos in the past, without issue.

Ian DXer
 

Hi Simon,

SB> As I wrote in another reply, I believe I have this problem fixed. Check whether you have FM Squelch enabled, if so disable it

Can you kindly go back & read my post  
is this thread.
Unless I'm mistaken(?) I fear my important added details (for you) of the fault description has been lost in all the noise
of the messages that followed....

Bill Walch's video does show the effect of the fault, with the exception that it doesn't show
the High Passfilter in Narrow FM being checked - this is part of the necessary bug criteria.
Also no pic of the squelch (but he later replied it was also disabled).

Again for the record FM Squelch was disabled in my case & seams to have no effect on the fault in my case.
Maybe we are talking about two separate problems here?

In a nutshell (as concise as I can describe it) - My required a setup to reproduce the fault (minimalist steps).
1. Stereo unchecked (MONO) in Broadcast FM
2. Highpass Filter checked (tick) in Narrow FM
3. BFM mode. Any VHF frequency (eg a FM BCB station)
4. Switch to NFM demodulation
5. Switch back to BFM --> audio fault condition now reproduced.

My screen shots as attachments in message  
visually describe (partly) the above.
My apologies (to Joanne, yourself & group) for the unintended 1st pic (and previous message post blurry pics).
The last two pics (attachments) of the three are those relevant & intended.

Bill Walch
 

I can confirm that Highpass Filter in Narrow FM being switched OFF will remedy the "tinny" condition in BFM mode when switching to Mono mode (or in fringe Stereo/Mono switching conditions).

On 9/9/2019 8:40 PM, Ian DXer wrote:
Hi Simon,

SB> As I wrote in another reply, I believe I have this problem fixed. Check whether you have FM Squelch enabled, if so disable it

Can you kindly go back & read my post  
is this thread.
Unless I'm mistaken(?) I fear my important added details (for you) of the fault description has been lost in all the noise
of the messages that followed....

Bill Walch's video does show the effect of the fault, with the exception that it doesn't show
the High Passfilter in Narrow FM being checked - this is part of the necessary bug criteria.
Also no pic of the squelch (but he later replied it was also disabled).

Again for the record FM Squelch was disabled in my case & seams to have no effect on the fault in my case.
Maybe we are talking about two separate problems here?

In a nutshell (as concise as I can describe it) - My required a setup to reproduce the fault (minimalist steps).
1. Stereo unchecked (MONO) in Broadcast FM
2. Highpass Filter checked (tick) in Narrow FM
3. BFM mode. Any VHF frequency (eg a FM BCB station)
4. Switch to NFM demodulation
5. Switch back to BFM --> audio fault condition now reproduced.

My screen shots as attachments in message  
visually describe (partly) the above.
My apologies (to Joanne, yourself & group) for the unintended 1st pic (and previous message post blurry pics).
The last two pics (attachments) of the three are those relevant & intended.