proxy authentication?


Ken , VK7KRJ <vk7krj@...>
 

Greetings all from a foggy and cold Tasmania (where we are repeatedly assured by our weather men that this is only temporary- they tell us it will definitely rain or go dark before morning).

I have a question about proxy authentication- when trying to use the console from inside the network at uni, it fails because the console is trying to go straight out instead of first authenticating (username and password) with the proxy.
This is not a problem with ports, we have sorted that out with the IT people by using port 443 which is already passed through the proxy's firewall.

Are there perchance any plans afoot to enable the console to first authenticate with a proxy before heading out into the big wide world?

If not, could I request that said plans be put on the "to-do" list for the console?


Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


Dom Baines M1KTA
 

Ken,

Why not ask the IT people to allow port 7900 through or define your own in the server? If you have to connect to a remote server on 7900 that doesn't help you if you do not have that port open.

This does work right now as I have used the IRC chat ports 6660-6664 at work successfully enough with a remote server at home and remote. 

72

Dom
M1KTA


--- On Tue, 25/5/10, Ken , VK7KRJ wrote:

From: Ken , VK7KRJ
Subject: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Tuesday, 25 May, 2010, 3:44

 

Greetings all from a foggy and cold Tasmania (where we are repeatedly
assured by our weather men that this is only temporary- they tell us it
will definitely rain or go dark before morning).

I have a question about proxy authentication- when trying to use the
console from inside the network at uni, it fails because the console is
trying to go straight out instead of first authenticating (username and
password) with the proxy.
This is not a problem with ports, we have sorted that out with the IT
people by using port 443 which is already passed through the proxy's firewall.

Are there perchance any plans afoot to enable the console to first
authenticate with a proxy before heading out into the big wide world?

If not, could I request that said plans be put on the "to-do" list for the
console?

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


-----Inline Attachment Follows-----


No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2894 - Release Date: 05/25/10 04:26:00


Simon HB9DRV <simon@...>
 

Hi,

 

Dom has the best solution - I know how to go out via a proxy, just haven't had time to do it.

 

Simon Brown, HB9DRV

http://sdr-radio.com

 

From: sdr-radio-com@... [mailto:sdr-radio-com@...] On Behalf Of Dominic Baines
Sent: 25 May 2010 13:06
To: sdr-radio-com@...
Subject: Re: [sdr-radio-com] proxy authentication?

 

 

Ken,

 

Why not ask the IT people to allow port 7900 through or define your own in the server? If you have to connect to a remote server on 7900 that doesn't help you if you do not have that port open.

 

This does work right now as I have used the IRC chat ports 6660-6664 at work successfully enough with a remote server at home and remote. 

 

72

 

Dom

M1KTA

--- On Tue, 25/5/10, Ken , VK7KRJ wrote:


From: Ken , VK7KRJ <vk7krj@...>
Subject: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Tuesday, 25 May, 2010, 3:44

 

Greetings all from a foggy and cold Tasmania (where we are repeatedly
assured by our weather men that this is only temporary- they tell us it
will definitely rain or go dark before morning).

I have a question about proxy authentication- when trying to use the
console from inside the network at uni, it fails because the console is
trying to go straight out instead of first authenticating (username and
password) with the proxy.
This is not a problem with ports, we have sorted that out with the IT
people by using port 443 which is already passed through the proxy's firewall.

Are there perchance any plans afoot to enable the console to first
authenticate with a proxy before heading out into the big wide world?

If not, could I request that said plans be put on the "to-do" list for the
console?

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


-----Inline Attachment Follows-----


No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2894 - Release Date: 05/25/10 04:26:00

 


Ken , VK7KRJ <vk7krj@...>
 

Dom, thanks for the reply, however the problem is not with the ports, it is with the authentication needed to access the external network.
From within the uni's intranet, when any program attempts to access the web, the proxy asks for a user name and password- my problem is the console is not set up to handle this, hence my attempt to connect fails because the proxy is asking for a user name and password which it never gets. I had a look and found this page for visual studio which seems to point to a solution

http://man.ddvip.com/web/bsaspnetapp/LiB0087.html





At 2010-05-25 21:06, you wrote:


Ken,

Why not ask the IT people to allow port 7900 through or define your own in the server? If you have to connect to a remote server on 7900 that doesn't help you if you do not have that port open.

This does work right now as I have used the IRC chat ports 6660-6664 at work successfully enough with a remote server at home and remote.

72

Dom
M1KTA
Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


jmiles56@sbcglobal.net <jmiles56@...>
 

The proxy side won't be the problem. Port 443 is a MS RPC port
used on the LAN side to regulate outgoing ports on firewall and
filter appliances. Dom is correct. Have the sysadmin open up a common
port range and use that. Ask them to open 443 on the WAN side
and they will probably bust a gut laughing..since DOS attacks will start
just as someone portscans their router. Just my 2 cents worth.

Jim

--- In sdr-radio-com@..., "Simon HB9DRV" <simon@...> wrote:

Hi,



Dom has the best solution - I know how to go out via a proxy, just haven't had time to do it.



Simon Brown, HB9DRV

http://sdr-radio.com



From: sdr-radio-com@... [mailto:sdr-radio-com@...] On Behalf Of Dominic Baines
Sent: 25 May 2010 13:06
To: sdr-radio-com@...
Subject: Re: [sdr-radio-com] proxy authentication?






Ken,



Why not ask the IT people to allow port 7900 through or define your own in the server? If you have to connect to a remote server on 7900 that doesn't help you if you do not have that port open.



This does work right now as I have used the IRC chat ports 6660-6664 at work successfully enough with a remote server at home and remote.



72



Dom

M1KTA

--- On Tue, 25/5/10, Ken , VK7KRJ <vk7krj@...> wrote:


From: Ken , VK7KRJ <vk7krj@...>
Subject: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Tuesday, 25 May, 2010, 3:44



Greetings all from a foggy and cold Tasmania (where we are repeatedly
assured by our weather men that this is only temporary- they tell us it
will definitely rain or go dark before morning).

I have a question about proxy authentication- when trying to use the
console from inside the network at uni, it fails because the console is
trying to go straight out instead of first authenticating (username and
password) with the proxy.
This is not a problem with ports, we have sorted that out with the IT
people by using port 443 which is already passed through the proxy's firewall.

Are there perchance any plans afoot to enable the console to first
authenticate with a proxy before heading out into the big wide world?

If not, could I request that said plans be put on the "to-do" list for the
console?

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


-----Inline Attachment Follows-----


No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2894 - Release Date: 05/25/10 04:26:00


Ken , VK7KRJ <vk7krj@...>
 

Guys- I thank you all for taking the time to reply to my query- but please, the PORT is not the problem, and they aren't opening 443 for me, we are using it because it's already there. The problem is with the AUTHENTICATION- username and password.

It was at the suggestion of the IT dept. that we changed to 443, as like most IT depts. in big organisations that I have had dealings with, they are stuck with the rules they have been given, and we have to find a way to use these rules to do what we need/want to. Especially when it's not work-related, and only for our own amusement during lunch hours and quiet periods.

I guess we will continue to be patient, after all it is only a hobby, and Simon is producing this great software for us out of nothing more than the goodness of his heart, for which I for one, am grateful.


At 2010-05-25 22:15, you wrote:
The proxy side won't be the problem. Port 443 is a MS RPC port
used on the LAN side to regulate outgoing ports on firewall and
filter appliances. Dom is correct. Have the sysadmin open up a common
port range and use that. Ask them to open 443 on the WAN side
and they will probably bust a gut laughing..since DOS attacks will start
just as someone portscans their router. Just my 2 cents worth.

Jim

--- In sdr-radio-com@..., "Simon HB9DRV" <simon@...> wrote:

Hi,



Dom has the best solution - I know how to go out via a proxy, just
haven't had time to do it.



Simon Brown, HB9DRV

http://sdr-radio.com



From: sdr-radio-com@...
[mailto:sdr-radio-com@...] On Behalf Of Dominic Baines
Sent: 25 May 2010 13:06
To: sdr-radio-com@...
Subject: Re: [sdr-radio-com] proxy authentication?






Ken,



Why not ask the IT people to allow port 7900 through or define your own
in the server? If you have to connect to a remote server on 7900 that doesn't help you if you do not have that port open.



This does work right now as I have used the IRC chat ports 6660-6664 at
work successfully enough with a remote server at home and remote.



72



Dom

M1KTA

--- On Tue, 25/5/10, Ken , VK7KRJ <vk7krj@...> wrote:


From: Ken , VK7KRJ <vk7krj@...>
Subject: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Tuesday, 25 May, 2010, 3:44



Greetings all from a foggy and cold Tasmania (where we are repeatedly
assured by our weather men that this is only temporary- they tell us it
will definitely rain or go dark before morning).

I have a question about proxy authentication- when trying to use the
console from inside the network at uni, it fails because the console is
trying to go straight out instead of first authenticating (username and
password) with the proxy.
This is not a problem with ports, we have sorted that out with the IT
people by using port 443 which is already passed through the proxy's
firewall.

Are there perchance any plans afoot to enable the console to first
authenticate with a proxy before heading out into the big wide world?

If not, could I request that said plans be put on the "to-do" list for the
console?
Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


Dom Baines M1KTA
 

I think you are going to be stuck but try this...

Set up a remote server OUTSIDE the university network (don't blame me if they get cross if you do this) and use port 443 or port 80 and try and connect to it. Do a connect externally first so you have the proxy doing it's thing. There are n different ways these things work and usually to stop you either looking at stuff you shouldn't or to stop bit torrent et al or to stop the Universities having to pay huge extra bandwidth charges (UK uni's got stung badly a few years back due to Napster and other bit torrent variants).

Or buy a wireless wifi connection dongle that doesn't use the uni network...

Or don't use remote servers...

Or get on with studying :-)

72

Dom
M1KTA


--- On Tue, 25/5/10, Ken , VK7KRJ wrote:

From: Ken , VK7KRJ
Subject: Re: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Tuesday, 25 May, 2010, 12:58

 

Dom, thanks for the reply, however the problem is not with the ports, it is
with the authentication needed to access the external network.
From within the uni's intranet, when any program attempts to access the
web, the proxy asks for a user name and password- my problem is the console
is not set up to handle this, hence my attempt to connect fails because the
proxy is asking for a user name and password which it never gets. I had a
look and found this page for visual studio which seems to point to a solution

http://man.ddvip.com/web/bsaspnetapp/LiB0087.html

At 2010-05-25 21:06, you wrote:

>Ken,
>
>Why not ask the IT people to allow port 7900 through or define your own in
>the server? If you have to connect to a remote server on 7900 that doesn't
>help you if you do not have that port open.
>
>This does work right now as I have used the IRC chat ports 6660-6664 at
>work successfully enough with a remote server at home and remote.
>
>72
>
>Dom
>M1KTA

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


-----Inline Attachment Follows-----


No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2894 - Release Date: 05/25/10 04:26:00


Dom Baines M1KTA
 

When I say... Do a connect externally first so you have the proxy doing it's thing.

I mean setup the external connection first, to the remote server IP... you will need a 'friend at that end' so you have a normal webserver on that IP first so the proxy says OK and allows the connection. Then change the webserver to now use the SDR-Radio remote server but keep the same IP and protocol (TCP)and fingers crossed should still work. I am not going to walk you through how to do any of this in detail.  

BTW cellphone/mobile phone wfi dongle technology is available in AUS.
e.g. http://www.vodafone.com.au/personal/live/index.htm so disconnect your laptop from the university network and use a wifi usb dongle.

I should say that network administrator protect networks for very good reasons so trying to go around the protection usually results in tears.

72
Dom
M1KTA

--- On Wed, 26/5/10, Dominic Baines <dombaines@...> wrote:

From: Dominic Baines <dombaines@...>
Subject: Re: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Wednesday, 26 May, 2010, 11:23

I think you are going to be stuck but try this...
Set up a remote server OUTSIDE the university network (don't blame me if they get cross if you do this) and use port 443 or port 80 and try and connect to it. Do a connect externally first so you have the proxy doing it's thing. There are n different ways these things work and usually to stop you either looking at stuff you shouldn't or to stop bit torrent et al or to stop the Universities having to pay huge extra bandwidth charges (UK uni's got stung badly a few years back due to Napster and other bit torrent variants).
Or buy a wireless wifi connection dongle that doesn't use the uni network...
Or don't use remote servers...
Or get on with studying
:-)
72
DomM1KTA

--- On Tue, 25/5/10, Ken , VK7KRJ <vk7krj@users. tasmanet. com.au> wrote:

From: Ken , VK7KRJ <vk7krj@users. tasmanet. com.au>
Subject: Re: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@ yahoogroups. com
Date: Tuesday, 25 May, 2010, 12:58
















 






Dom, thanks for the reply, however the problem is not with the ports, it is

with the authentication needed to access the external network.

From within the uni's intranet, when any program attempts to access the

web, the proxy asks for a user name and password- my problem is the console

is not set up to handle this, hence my attempt to connect fails because the

proxy is asking for a user name and password which it never gets. I had a

look and found this page for visual studio which seems to point to a solution



http://man.ddvip. com/web/bsaspnet app/LiB0087. html



At 2010-05-25 21:06, you wrote:



Ken,
Why not ask the IT people to allow port 7900 through or define your own in
the server? If you have to connect to a remote server on 7900 that doesn't
help you if you do not have that port open.
This does work right now as I have used the IRC chat ports 6660-6664 at
work successfully enough with a remote server at home and remote.
72
Dom
M1KTA


Cheers, Ken

vk7krj@users. tasmanet. com.au

www.vk7krj.com



'It seems hard to sneak a look at God's cards. But that He plays dice and uses

"telepathic" methods .... is something that I cannot believe for a single

moment.' (Einstein's famous quote on Quantum theory)

















-----Inline Attachment Follows-----


No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2894 - Release Date: 05/25/10 04:26:00


Simon HB9DRV <simon@...>
 

Cruel :)

 

Simon Brown, HB9DRV

http://sdr-radio.com

 

From: sdr-radio-com@... [mailto:sdr-radio-com@...] On Behalf Of Dominic Baines

 

Or get on with studying :-)

 

72

 


Dom Baines M1KTA
 

Apologies Ken and Simon et al...

I got me wrist slapped at Uni' a long time ago (early 80's) for something similar and that was what I was told.

The whole protected network thing effects me too as I tend to work behind seriously protected networks and you learn the 'cracks'. The dial up authentication method is usually always a 100% block to everything that isn't on a very small defined port list (hotel chains, cyber cafe's and those pay by the minute internet connection cards often use this method a lot). There might be no option but to get an unprotected connection and use that. 

Now at work I have to use a Wifi Dongle with a 3MB/s connection as I cannot get through the firewalls.

72

Dom
M1KTA


--- On Wed, 26/5/10, Simon HB9DRV wrote:

From: Simon HB9DRV
Subject: RE: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Wednesday, 26 May, 2010, 11:40

 

Cruel :)

 

Simon Brown, HB9DRV

http://sdr-radio. com

 

From: sdr-radio-com@ yahoogroups. com [mailto:sdr- radio-com@ yahoogroups. com] On Behalf Of Dominic Baines

 

Or get on with studying :-)

 

72

 



jmiles56@sbcglobal.net <jmiles56@...>
 

Hi Ken

Well if it's only lunch and free time I guess it's not
really worth the hassle with IT. You could do a cellular connect via
a USB air card..but if they have the netwok cranked down that tight
then chances are you won't have ADMin rights to install it. Good luck
in your endevors. Now if Simon would come out with a iPhone app..:-)

Jim

--- In sdr-radio-com@..., "Ken , VK7KRJ" <vk7krj@...> wrote:

Guys- I thank you all for taking the time to reply to my query- but please,
the PORT is not the problem, and they aren't opening 443 for me, we are
using it because it's already there. The problem is with the
AUTHENTICATION- username and password.

It was at the suggestion of the IT dept. that we changed to 443, as like
most IT depts. in big organisations that I have had dealings with, they are
stuck with the rules they have been given, and we have to find a way to use
these rules to do what we need/want to. Especially when it's not
work-related, and only for our own amusement during lunch hours and quiet
periods.

I guess we will continue to be patient, after all it is only a hobby, and
Simon is producing this great software for us out of nothing more than the
goodness of his heart, for which I for one, am grateful.


At 2010-05-25 22:15, you wrote:
The proxy side won't be the problem. Port 443 is a MS RPC port
used on the LAN side to regulate outgoing ports on firewall and
filter appliances. Dom is correct. Have the sysadmin open up a common
port range and use that. Ask them to open 443 on the WAN side
and they will probably bust a gut laughing..since DOS attacks will start
just as someone portscans their router. Just my 2 cents worth.

Jim

--- In sdr-radio-com@..., "Simon HB9DRV" <simon@> wrote:

Hi,



Dom has the best solution - I know how to go out via a proxy, just
haven't had time to do it.



Simon Brown, HB9DRV

http://sdr-radio.com



From: sdr-radio-com@...
[mailto:sdr-radio-com@...] On Behalf Of Dominic Baines
Sent: 25 May 2010 13:06
To: sdr-radio-com@...
Subject: Re: [sdr-radio-com] proxy authentication?






Ken,



Why not ask the IT people to allow port 7900 through or define your own
in the server? If you have to connect to a remote server on 7900 that
doesn't help you if you do not have that port open.



This does work right now as I have used the IRC chat ports 6660-6664 at
work successfully enough with a remote server at home and remote.



72



Dom

M1KTA

--- On Tue, 25/5/10, Ken , VK7KRJ <vk7krj@> wrote:


From: Ken , VK7KRJ <vk7krj@>
Subject: [sdr-radio-com] proxy authentication?
To: sdr-radio-com@...
Date: Tuesday, 25 May, 2010, 3:44



Greetings all from a foggy and cold Tasmania (where we are repeatedly
assured by our weather men that this is only temporary- they tell us it
will definitely rain or go dark before morning).

I have a question about proxy authentication- when trying to use the
console from inside the network at uni, it fails because the console is
trying to go straight out instead of first authenticating (username and
password) with the proxy.
This is not a problem with ports, we have sorted that out with the IT
people by using port 443 which is already passed through the proxy's
firewall.

Are there perchance any plans afoot to enable the console to first
authenticate with a proxy before heading out into the big wide world?

If not, could I request that said plans be put on the "to-do" list for the
console?
Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)



No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2896 - Release Date: 05/26/10 04:26:00


Ken , VK7KRJ <vk7krj@...>
 

Now that suggestion really is mean!!

At 2010-05-26 20:40, you wrote:



Or get on with studying :-)
Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


Ken , VK7KRJ <vk7krj@...>
 

It has just occurred to me, a better way for me to go may be to build another server box and softrock v9, and put that on the top floor with a covert antenna. All I need then is a spare bit of cat5 down to the office. Humm......

At 2010-05-26 20:47, you wrote:


Apologies Ken and Simon et al...

I got me wrist slapped at Uni' a long time ago (early 80's) for something similar and that was what I was told.

The whole protected network thing effects me too as I tend to work behind seriously protected networks and you learn the 'cracks'. The dial up authentication method is usually always a 100% block to everything that isn't on a very small defined port list (hotel chains, cyber cafe's and those pay by the minute internet connection cards often use this method a lot). There might be no option but to get an unprotected connection and use that.

Now at work I have to use a Wifi Dongle with a 3MB/s connection as I cannot get through the firewalls.

72

Dom
M1KTA
Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


pe0fko
 

Hi Ken,

Maybe ProxyTunnel can support you .
It will create a tunnel through a authenticated proxy server to a extern IP address and port.
Did not use it for a long time, but think you must run it as a local server on your win system and the application (sdr-radio) must connect to the localhost : port.

73, Fred
PE0FKO

On 26-5-2010 06:37, Ken , VK7KRJ wrote:
 

Guys- I thank you all for taking the time to reply to my query- but please,
the PORT is not the problem, and they aren't opening 443 for me, we are
using it because it's already there. The problem is with the
AUTHENTICATION- username and password.

It was at the suggestion of the IT dept. that we changed to 443, as like
most IT depts. in big organisations that I have had dealings with, they are
stuck with the rules they have been given, and we have to find a way to use
these rules to do what we need/want to. Especially when it's not
work-related, and only for our own amusement during lunch hours and quiet
periods.

I guess we will continue to be patient, after all it is only a hobby, and
Simon is producing this great software for us out of nothing more than the
goodness of his heart, for which I for one, am grateful.

At 2010-05-25 22:15, you wrote:
>The proxy side won't be the problem. Port 443 is a MS RPC port
>used on the LAN side to regulate outgoing ports on firewall and
>filter appliances. Dom is correct. Have the sysadmin open up a common
>port range and use that. Ask them to open 443 on the WAN side
>and they will probably bust a gut laughing..since DOS attacks will start
>just as someone portscans their router. Just my 2 cents worth.
>
>Jim
>
>--- In sdr-radio-com@..., "Simon HB9DRV" wrote:
> >
> > Hi,
> >
> >
> >
> > Dom has the best solution - I know how to go out via a proxy, just
> haven't had time to do it.
> >
> >
> >
> > Simon Brown, HB9DRV
> >
> > http://sdr-radio.com
> >
> >
> >
> > From: sdr-radio-com@...
> [mailto:sdr-radio-com@...] On Behalf Of Dominic Baines
> > Sent: 25 May 2010 13:06
> > To: sdr-radio-com@...
> > Subject: Re: [sdr-radio-com] proxy authentication?
> >
> >
> >
> >
> >
> >
> > Ken,
> >
> >
> >
> > Why not ask the IT people to allow port 7900 through or define your own
> in the server? If you have to connect to a remote server on 7900 that
> doesn't help you if you do not have that port open.
> >
> >
> >
> > This does work right now as I have used the IRC chat ports 6660-6664 at
> work successfully enough with a remote server at home and remote.
> >
> >
> >
> > 72
> >
> >
> >
> > Dom
> >
> > M1KTA
> >
> > --- On Tue, 25/5/10, Ken , VK7KRJ wrote:
> >
> >
> > From: Ken , VK7KRJ
> > Subject: [sdr-radio-com] proxy authentication?
> > To: sdr-radio-com@...
> > Date: Tuesday, 25 May, 2010, 3:44
> >
> >
> >
> > Greetings all from a foggy and cold Tasmania (where we are repeatedly
> > assured by our weather men that this is only temporary- they tell us it
> > will definitely rain or go dark before morning).
> >
> > I have a question about proxy authentication- when trying to use the
> > console from inside the network at uni, it fails because the console is
> > trying to go straight out instead of first authenticating (username and
> > password) with the proxy.
> > This is not a problem with ports, we have sorted that out with the IT
> > people by using port 443 which is already passed through the proxy's
> firewall.
> >
> > Are there perchance any plans afoot to enable the console to first
> > authenticate with a proxy before heading out into the big wide world?
> >
> > If not, could I request that said plans be put on the "to-do" list for the
> > console?

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)



No virus found in this outgoing message.
Checked by AVG - www.avg.com 
Version: 9.0.819 / Virus Database: 271.1.1/2896 - Release Date: 05/26/10 04:26:00

  


Ken , VK7KRJ <vk7krj@...>
 

Just had a read of that site Fred, it looks very promising, I will have a better read when I have had some sleep (it's 1:30am here and I really shouldn't be still be fiddling with computers...)


At 2010-05-27 00:31, you wrote:


Hi Ken,

Maybe ProxyTunnel can support you <http://proxytunnel.sourceforge.net/>.
It will create a tunnel through a authenticated proxy server to a extern IP address and port.
Did not use it for a long time, but think you must run it as a local server on your win system and the application (sdr-radio) must connect to the localhost : port.

73, Fred
PE0FKO
Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)


Joseph Barger
 

Hi Ken,

I had the same problem.  How to get programs that don't support http proxy authentication (user name, password) through the proxy firewall at work.

Try Super Socks5Cap (google it).  It supports HTTPS proxy authentication.  After you set it up, Super Socks5Cap handles the proxy authentication for programs run from (or on top of) it.

Free 30 day trial, $29 after that.  Works great for me.

No connection with the company, just a satisfied customer.

joe n6kk

And running unauthorized tunnels through firewalls may work ... may also get you fired.




On Wed, May 26, 2010 at 8:24 AM, Ken , VK7KRJ <vk7krj@...> wrote:
 

Just had a read of that site Fred, it looks very promising, I will have a
better read when I have had some sleep (it's 1:30am here and I really
shouldn't be still be fiddling with computers...)



At 2010-05-27 00:31, you wrote:

>Hi Ken,
>
>Maybe ProxyTunnel can support you <http://proxytunnel.sourceforge.net/>.
>It will create a tunnel through a authenticated proxy server to a extern
>IP address and port.
>Did not use it for a long time, but think you must run it as a local
>server on your win system and the application (sdr-radio) must connect to
>the localhost : port.
>
>73, Fred
>PE0FKO

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)



No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2897 - Release Date: 05/26/10 16:25:00



Simon HB9DRV <simon@...>
 

BTW, make sure that the firewall allows all protocols after authentication.

 

Simon Brown, HB9DRV

http://sdr-radio.com

 

From: sdr-radio-com@... [mailto:sdr-radio-com@...] On Behalf Of Joe Barger
Sent: 27 May 2010 21:03
To: sdr-radio-com@...
Subject: Re: [sdr-radio-com] Re: proxy authentication?

 

 

Hi Ken,

I had the same problem.  How to get programs that don't support http proxy authentication (user name, password) through the proxy firewall at work.

Try Super Socks5Cap (google it).  It supports HTTPS proxy authentication.  After you set it up, Super Socks5Cap handles the proxy authentication for programs run from (or on top of) it.

Free 30 day trial, $29 after that.  Works great for me.

No connection with the company, just a satisfied customer.

joe n6kk

And running unauthorized tunnels through firewalls may work ... may also get you fired.



On Wed, May 26, 2010 at 8:24 AM, Ken , VK7KRJ <vk7krj@...> wrote:

 

Just had a read of that site Fred, it looks very promising, I will have a
better read when I have had some sleep (it's 1:30am here and I really
shouldn't be still be fiddling with computers...)



At 2010-05-27 00:31, you wrote:

>Hi Ken,
>
>Maybe ProxyTunnel can support you <http://proxytunnel.sourceforge.net/>.
>It will create a tunnel through a authenticated proxy server to a extern
>IP address and port.
>Did not use it for a long time, but think you must run it as a local
>server on your win system and the application (sdr-radio) must connect to
>the localhost : port.
>
>73, Fred
>PE0FKO

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)



No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2897 - Release Date: 05/26/10 16:25:00

 


Joseph Barger
 



Good point ... our firewall only allows http/https (no telnet, etc.) even after authentication. 

joe n6kk



On Thu, May 27, 2010 at 12:06 PM, Simon HB9DRV <simon@...> wrote:
 

BTW, make sure that the firewall allows all protocols after authentication.

 

Simon Brown, HB9DRV

http://sdr-radio.com

 

From: sdr-radio-com@... [mailto:sdr-radio-com@...] On Behalf Of Joe Barger
Sent: 27 May 2010 21:03

Subject: Re: [sdr-radio-com] Re: proxy authentication?

 

 

Hi Ken,

I had the same problem.  How to get programs that don't support http proxy authentication (user name, password) through the proxy firewall at work.

Try Super Socks5Cap (google it).  It supports HTTPS proxy authentication.  After you set it up, Super Socks5Cap handles the proxy authentication for programs run from (or on top of) it.

Free 30 day trial, $29 after that.  Works great for me.

No connection with the company, just a satisfied customer.

joe n6kk

And running unauthorized tunnels through firewalls may work ... may also get you fired.



On Wed, May 26, 2010 at 8:24 AM, Ken , VK7KRJ <vk7krj@...> wrote:

 

Just had a read of that site Fred, it looks very promising, I will have a
better read when I have had some sleep (it's 1:30am here and I really
shouldn't be still be fiddling with computers...)



At 2010-05-27 00:31, you wrote:

>Hi Ken,
>
>Maybe ProxyTunnel can support you <http://proxytunnel.sourceforge.net/>.
>It will create a tunnel through a authenticated proxy server to a extern
>IP address and port.
>Did not use it for a long time, but think you must run it as a local
>server on your win system and the application (sdr-radio) must connect to
>the localhost : port.
>
>73, Fred
>PE0FKO

Cheers, Ken
vk7krj@...
www.vk7krj.com

'It seems hard to sneak a look at God's cards. But that He plays dice and uses
"telepathic" methods .... is something that I cannot believe for a single
moment.' (Einstein's famous quote on Quantum theory)



No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 9.0.819 / Virus Database: 271.1.1/2897 - Release Date: 05/26/10 16:25:00