Topics

Ettus USRP B200 Mini audio problem above 14 MHz

HF Seattle
 

   Hello group I am looking for help on my B200 mini  I have the radio plugged in to my laptop directly and this is the only device on USB.  Audio is fine at 14MHz but starts skipping bad at 28MHz.   Laptop has a i7 8th gen.  Thanks for any help in advance. 

erik@...
 

OH, this is disturbing to read!!!

I am in the same boat with my B210, and thought I was merely overloading my first-gen USB 3.0 (5Gb/s) when I was getting stuttering at 28MHz bandwidth and beyond. Expecting that a standard USB3.1 (10Gb/s) interface on a new laptop would cure it, and since I'm on the road, I was looking forward to putting this on my Desktop when next home, given that it has the newer 'blue', USB port.

So I guess I am to get 7MHz bandwidth then, should I ever figure out how to enable the second receiver?!?

Hardly, the 2x 56MHz I forked out for....

HF Seattle
 

Anyone else with a B200 having this problem?  

erik@...
 

Hi Pal,

As I read it on Ettus.com just now:

Begin Paste>

When can I power the USRP B200/B210/B200mini off the USB bus?

The experience may vary across various controllers. Generally speaking, bus-power is ideal for SISO operation. If you are using both channels of a USRP B210 we recommend an external power supply. We provide a power supply with the USRP B210.

MIMO operation with the USRP B210 is not recommended when using the USRP B210 on bus-power.

You should not attempt to run the device on bus-power if a GPS-disciplined oscillator is installed.


How much power does the USRP consume?

The table below shows power consumption (Watts) of a USRP B210 run with a 6V power supply. Figures on a 5V supply (USB power), or with a USRP B200 will be moderately lower. The sample rates shown are aggregate sample rates on the USB 3.0 interface.

  5 Msps 15.36 Msps 30.72 Msps 56 Msps 61.44 Msps
1 RX 1.92 2.112 2.184 2.508  
2 RX 2.148 2.436 2.508 2.64  
1 TX 2.184 2.34 2.352 2.22  
2 TX 2.76 2.88 2.904 2.64  
Full Duplex (1x1) 2.508 2.736 2.796 3.168  
2x2 MIMO 3.252 3.588 3.672 4.11 4.092


<End Paste

Since I AM running mine with the GPSDO fitted, I guess I should be happy it runs at all.

I did see 45MHz bandwidth with a spectrum analyser program, but it crashed / became unresponsive at anything higher.

So, ID10T error (for now).

Since I'm at the 'winter home' in Thailand, I don't have my PSU with me (doh), and sending anything here is a pain, so I have opted to locally order a USB3.0 'Y' cable, so I can attempt to feed the B210 with double port current. I will post again when I receive that to see if we can get 28MHz bandwidth going at least.

Then we can see where we stand on current at least, though I do recognize this is not the manuf's accepted solution. And given the cost of this device, I am loathed to plug in ANY off-the-shelf Chinese no-name AC-DC adapter, if you get me.

My kingdom for a clean bench PSU.

Erik.

HF Seattle
 

This looks like a separate issue my problem is with the B200 Mini in RX mode I don't think its a power problem. Does anyone have a B200 mini they could test?

HF Seattle
 

   Any B200 mini folks have any ideas?

HF Seattle
 

    Anyone have this same problem with a B200 Mini? 

HF Seattle
 

     Any input would be a great  group this is the only radio I am having trouble with please let me know if it looks like I have something set wrong.

erik@...
 

My B210 running (with awful antenna sorry) at 28MHz (shown). I played around with buffers, I tried a 'Y' USB cable to provide more current, and pulled my DSO from the board (I don't have my PSU with me to run it).

I also found out I at some point, was a mere 2C from Thermally-throttling on my CPU, with constant Power & Current limits being activated / reported by Intel's Extreme Tuning Utility program. I upped all those current limits, under-volted slightly, and tried both IPP and CUDA modes, and voila - it worked. 56MHz bandwidth is still out of reach though.

Did you try CUDA mode (assuming you have an Nvidia GPU)? IPP seems a tiny bit 'better', but hits over 50% CPU pretty much constantly. CUDA draws <30% load from a 1070M (which is a bit wider than its Desktop brethren, but lower clocks).

Specs 4940MX @ 4.4GHz, 1070M standard clocks (as always), 16GB RAM removed to allow 2133MHz as 32GB runs 1866MHz only.

Hope that helps in some way. Tinkering done for the day.

HF Seattle
 

  Thanks I do not have a GPU I think My i7 just can not handle 28MHz