Cant get Console to run


steve davies
 

Hi I cant get console to run even though its loading ok. I also use sdruno which seems fine. Console is seeing the sdrplay as a definition but wont run it. Any help greatly appreciated thanks..


Kriss Kliegle KA1GJU
 

First, open SDRC all the way so we can see all the data provided, it's not full screen by looking at the box in upper right.
There's a whole lot of data along the bottom that's missing. Best to use the screen shot button w/in SDRC, not the Print Screen of Windows.
OTW reboot, delete definition of the SDRPlay and rebuild a new definition.

Are you sure the proper drivers installed for the RSPduo?
I see the following, but Simon will chime in when he has time...


14:22:19.686: Radio SDRplayV3: Update> sdrplay_api_Update call 1 failed ***
14:22:19.696: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:19.696: Radio SDRplayV3: Update>   Tuner ......: A
14:22:19.696: Radio SDRplayV3: Update>   Reason .....: RspDuo_RfDabNotchControl
14:22:19.696: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:19.696: Radio SDRplayV3: Update>   Status .....: sdrplay_api_OutOfRange
14:22:19.696: Radio SDRplayV3: Update> -
14:22:19.696: Radio SDRplayV3: Update DAB Notch> sdrplay_api_Update failed: sdrplay_api_OutOfRange
14:22:19.696: Radio SDRplayV3: AltValue Apply> AltValue-RSPduo-1809003932-OPT_DAB_NOTCH, value 0
14:22:19.696: Radio SDRplayV3: Update Bias-T> New value 0
14:22:19.696: Radio SDRplayV3: Update> sdrplay_api_Update call 1 failed ***
14:22:19.696: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:19.696: Radio SDRplayV3: Update>   Tuner ......: A
14:22:19.696: Radio SDRplayV3: Update>   Reason .....: RspDuo_BiasTControl
14:22:19.696: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:19.696: Radio SDRplayV3: Update>   Status .....: sdrplay_api_InvalidParam
14:22:19.696: Radio SDRplayV3: Update> -
14:22:19.696: Radio SDRplayV3: Update Bias-T> sdrplay_api_Update failed: sdrplay_api_InvalidParam
14:22:19.696: Radio SDRplayV3: AltValue Apply> AltValue-RSPduo-1809003932-OPT_BIAST, value 0
14:22:19.696: Radio SDRplayV3: Update Ext. Reference> New value 0
14:22:19.756: Radio SDRplayV3: AltValue Apply> AltValue-RSPduo-1809003932-OPT_REFERENCE, value 0
14:22:19.756: Radio SDRplayV3: Update Duo Tuner> New value A (1)
14:22:19.756: Radio SDRplayV3: Update Duo Tuner> Restarting
14:22:19.756: Radio SDRplayV3: Stop> Calling sdrplay_api_Uninit
14:22:19.906: Radio SDRplayV3: Stop> OK
14:22:19.906: Radio SDRplayV3: Start> Calling sdrplay_api_Init
14:22:19.906: Radio SDRplayV3: Update> sdrplay_api_Update call 1 failed ***
14:22:19.906: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:19.906: Radio SDRplayV3: Update>   Tuner ......: A
14:22:19.906: Radio SDRplayV3: Update>   Reason .....: Ctrl_OverloadMsgAck
14:22:19.906: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:19.906: Radio SDRplayV3: Update>   Status .....: sdrplay_api_NotInitialised
14:22:19.916: Radio SDRplayV3: Update> -
14:22:19.946: Radio SDRplayV3: Start> sdrplay_api_Init failed: sdrplay_api_Fail
14:22:19.946: Radio SDRplayV3: Update> sdrplay_api_Update call 2 failed ***
14:22:19.946: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:19.946: Radio SDRplayV3: AltValue Apply> AltValue-RSPduo-1809003932-OPT_DUO_TUNER, value 1
14:22:19.946: Radio SDRplayV3: Update>   Tuner ......: A
14:22:19.946: Radio SDRplayV3: Update>   Reason .....: Ctrl_OverloadMsgAck
14:22:19.946: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:19.946: Radio SDRplayV3: Update>   Status .....: sdrplay_api_NotInitialised
14:22:19.946: Radio SDRplayV3: Update> -
14:22:19.976: Radio SDRplayV3: Update> sdrplay_api_Update call 3 failed ***
14:22:19.976: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:19.976: Radio SDRplayV3: Update>   Tuner ......: A
14:22:19.976: Radio SDRplayV3: Update>   Reason .....: Ctrl_OverloadMsgAck
14:22:19.976: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:19.976: Radio SDRplayV3: Update>   Status .....: sdrplay_api_NotInitialised
14:22:19.976: Radio SDRplayV3: Update> -
14:22:20.006: Radio SDRplayV3: Update> sdrplay_api_Update call 4 failed ***
14:22:20.006: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:20.006: Radio SDRplayV3: Update>   Tuner ......: A
14:22:20.006: Radio SDRplayV3: Update>   Reason .....: Ctrl_OverloadMsgAck
14:22:20.006: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:20.006: Radio SDRplayV3: Update>   Status .....: sdrplay_api_NotInitialised
14:22:20.006: Radio SDRplayV3: Update> -
14:22:20.036: Radio SDRplayV3: Update> sdrplay_api_Update call 5 failed ***
14:22:20.036: Radio SDRplayV3: Update>   HANDLE .....: 12BA9E00
14:22:20.036: Radio SDRplayV3: Update>   Tuner ......: A
14:22:20.036: Radio SDRplayV3: Update>   Reason .....: Ctrl_OverloadMsgAck
14:22:20.036: Radio SDRplayV3: Update>   Extension ..: Ext1_None
14:22:20.036: Radio SDRplayV3: Update>   Status .....: sdrplay_api_NotInitialised

Just thinking out loud here...

73 Kriss KA1GJU


Dennis Matzen
 

Attached is my log file for the RSPduo. Two things I see that may be an issue. I have API ver 3.08, you are using 3.09 and it shows the local version is 3.06. I think Simon has said 3.09 will work but that may be a fix in one of the beta releases. I am running build 2470, you might try updating.

The other thing I see is that your process is an Atom. I know it is supported but not sure if has any affect on what you are seeing. 

So you might try changing the API ver to 3.08 and  upgrade Console to latest beta. Note I find that whenever updating the SDRplay software it is best to unplug receiver, remove old software (Uno and all drivers) then install new software and only plug the receiver in when directed by the installation.
--
Dennis
KA6FUB


Dennis Matzen
 

Steve, I figured I would try upgrading the SRDplay software on my system to see if it made any difference. As you can see in the attached log I now have API ver 3.09. But Console is still working OK. Log shows a API mis-match but ver 3.09 was used. 

I guess thing to try is the latest beta version of Console.
--
Dennis
KA6FUB


steve davies
 

Many thanks for the replies to my query..I'll have a ho at some of the suggestions..thanks


On Sun, Jan 23, 2022, 6:57 PM Dennis Matzen <ka6fub@...> wrote:
Steve, I figured I would try upgrading the SRDplay software on my system to see if it made any difference. As you can see in the attached log I now have API ver 3.09. But Console is still working OK. Log shows a API mis-match but ver 3.09 was used. 

I guess thing to try is the latest beta version of Console.
--
Dennis
KA6FUB


Dennis Matzen
 

Steve, did you get this resolved? If so what was it?
--
Dennis
KA6FUB