2365 Beta won't start the RSPduo. This worked fine in version 2346 #bug


k9ao@...
 

I just loaded the 2365 beta and the RSPduo won't start. It looks like it does but nothing happens after clicking on the SDR on the opening screen.

The previous version 2346 worked fine.

Any thoughts?

Rick Kunath, K9AO


Mike Bott
 

I'd start here:  https://www.sdr-radio.com/usb

--
Mike

On 9/18/2021 18:24:45, k9ao via groups.io wrote:
I just loaded the 2365 beta and the RSPduo won't start. It looks like it does but nothing happens after clicking on the SDR on the opening screen.

The previous version 2346 worked fine.

Any thoughts?

Rick Kunath, K9AO


k9ao@...
 

Thanks Mike, but the SDR does work fine on SDRuno and other apps on Linux.

It did work on the last beta, just not on this one. 

Doubtful it's the USB. It does see the radio, tries to start it, just nothing ever happens after that.

I should have not forgotten to mention that important detail.

Rick


agene
 

The 2365 beta will not start with the RSPdx either. It does open and after a while, you can change the freq etc, but nothing is received and the 'Radio' section of the toolbar is mainly greyed out, boxes like 'Bias-t' do not appear at all. I will stick with v3.1 for time being, it works well.

Mike Simpson.



On 19/09/2021 8:24 am, k9ao via groups.io wrote:
I just loaded the 2365 beta and the RSPduo won't start. It looks like it does but nothing happens after clicking on the SDR on the opening screen.

The previous version 2346 worked fine.

Any thoughts?

Rick Kunath, K9AO


Mike Bott
 

Rick, I hear what you are saying.  Note however, that my RSPduo & my RSP2 are both currently running under the 2365 beta.  Until I made the USB changes, I would ocassionaly experience the the exact issue you describe.  I *assume* you are having issues with the V3 definition for the RSPduo.  What about the V2 definition?  Does it still runs? 

This issue I was having never interfered with SDRuno or HDSDR.

Got entries in the log with repeats of :  Radio SDRplayV3: Update> sdrplay_api_Update call 1 failed ***  ?  Maybe 5 times or so?

--
Mike


On 9/18/2021 19:51:29, k9ao via groups.io wrote:

Thanks Mike, but the SDR does work fine on SDRuno and other apps on Linux.

It did work on the last beta, just not on this one. 

Doubtful it's the USB. It does see the radio, tries to start it, just nothing ever happens after that.

I should have not forgotten to mention that important detail.

Rick

_


k9ao@...
 

I actually do have that StarTech PCIe card Mike and it's separately powered. The only thing on the card USB port for the radio is the radio, and it's got a shielded USB cable and ferrites at each end too.

But whoa, your mention of the V2 and V3 got me going. Both my 2 Pro and Duo were using the V2 defs. I didn't realize I needed to delete these old definitions and re-add them as V3 definitions.

Once I did that everything works perfectly so far.

You are the man Mike :) thanks so much.

Rick


agene
 

Further to my earlier post, I can confirm that build 2365 is also working on my RSPdx. After I had rebooted my machine twice, the new build started working OK. This had nothing to do with V2 or V3 as I am using a newly built PC which had no other versions of SDR-Console or other RSP radios installed.

Thanks to everyone, especially Simon for this great software.

Mike Simpson, South Penrith, NSW


On 19/09/2021 11:20 am, k9ao via groups.io wrote:
I actually do have that StarTech PCIe card Mike and it's separately powered. The only thing on the card USB port for the radio is the radio, and it's got a shielded USB cable and ferrites at each end too.

But whoa, your mention of the V2 and V3 got me going. Both my 2 Pro and Duo were using the V2 defs. I didn't realize I needed to delete these old definitions and re-add them as V3 definitions.

Once I did that everything works perfectly so far.

You are the man Mike :) thanks so much.

Rick


Mike G0LQI
 

Hi Rick,
I have noted the same effect since the previous beta. On my system, SDRC doesn't start the SDRPlay API. If I run SDRUno briefly before hand, then SDRC starts fine thereafter until the next reboot.
73 Mike G0LQI


Simon Brown
 

OK,

 

I’ll check this out…

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Mike G0LQI via groups.io
Sent: 19 September 2021 09:46
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] 2365 Beta won't start the RSPduo. This worked fine in version 2346 #bug

 

Hi Rick,
I have noted the same effect since the previous beta. On my system, SDRC doesn't start the SDRPlay API. If I run SDRUno briefly before hand, then SDRC starts fine thereafter until the next reboot.
73 Mike G0LQI


--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Frank
 

For info:
Check and USE 2365 on SDRPLAY RSP2 without problem!

I Change the V3 startup default for to add the new V3 after install new SDRuno with API 3.08

All OK on SDRconsole 3.1 Beta 2365 and SDRuno v1.41


73


k9ao@...
 

2365 also starts up correctly for me here too.

From a cold boot, I start 2365 and the API comes up, I select the radio, and it works. That's without running SDRuno first.

Rick Kunath, K9AO


Brent Seres/ VE3CUS
 

FWIW,  I have a RSP2, and the latest version starts fine. Initial impressions suggest playback is smoother than previous releases.

73
Brent





k9ao@...
 

I should have added for Simon that I am using the latest SDRuno 1.41 and I have the latest SDRplay 3.08 API installed.

Again, running fine now that I have a V3 definition :)

Rick Kunath, K9AO


Mike Bott
 

Just for grins, I loaded both the beta build 2365 and SDRuno 1.41 on my 2012 HP Pavilion g-series running Win 8.1 on an AMD A6 cpu with no gpu.  Both appear to run well.  I felt 7.4% on the cpu was a respectable number for Console.

--
Mike

On 9/19/2021 16:01:04, k9ao via groups.io wrote:
I should have added for Simon that I am using the latest SDRuno 1.41 and I have the latest SDRplay 3.08 API installed.

Again, running fine now that I have a V3 definition :)

Rick Kunath, K9AO


Frank
 

Hi,

SDRconsole + SDRplay RSP2 v3.08 API + V3.1 2365Beta 

I don't know if it's just my problem, but with SDRplay RSP2 V3.08 it works perfectly but DOES NOT RECEIVE if I set the BANDWIDTH to 10MHz, it only works up to 8MHz.
 
By putting 10MHz Bandwidth, RX audio does not start, the WF does not flow and nothing is heard.
 
I can use 8MHz BW at most. The SDRconsole doesn't freeze, but I have to go back and use 8MHz max.

With the SDRplay RSP2 V2 in SDRconsole NO PROBLEM also with 10MHz BW.

73



Dale Elshoff WB8CJW <dale.elshoff@...>
 

Just ran my RSPdx at 10 MHz. and see no problem.  Screenshot attached.
Dale





On 9/20/2021 9:04 AM, Frank wrote:
Hi,

SDRconsole + SDRplay RSP2 v3.08 API + V3.1 2365Beta 

I don't know if it's just my problem, but with SDRplay RSP2 V3.08 it works perfectly but DOES NOT RECEIVE if I set the BANDWIDTH to 10MHz, it only works up to 8MHz.
 
By putting 10MHz Bandwidth, RX audio does not start, the WF does not flow and nothing is heard.
 
I can use 8MHz BW at most. The SDRconsole doesn't freeze, but I have to go back and use 8MHz max.

With the SDRplay RSP2 V2 in SDRconsole NO PROBLEM also with 10MHz BW.

73




Frank
 

Unfortunately with SDRplay model RSP2 it does not work here with 10MHz, only up to 8MHz without problem...
If I load SDRuno at 10MHz it works but unfortunately 10MHz <> it does not start with SDRconsole.
 
I don't know if there are other users with RSP2 who could try 10MHz BW?


Simon Brown
 

Logfile?

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Frank
Sent: 21 September 2021 16:01
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] 2365 Beta won't start the RSPduo. This worked fine in version 2346 #bug

 

Unfortunately with SDRplay model RSP2 it does not work here with 10MHz, only up to 8MHz without problem...

If I load SDRuno at 10MHz it works but unfortunately 10MHz <> it does not start with SDRconsole.

 

I don't know if there are other users with RSP2 who could try 10MHz BW?


--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Brent Seres/ VE3CUS
 

I must be doing something wrong, because in my bandwidth menu, with the RSP2,  my maximum bandwidth available is 1 Mhz. That being said, I am running the radio on an old computer running windows 7 in the basement which acts as a server and the actual console is on a new windows 10 machine. Any thoughts? Not a big deal, just wondering. 

Brent 
VE3CUS 





Simon Brown
 

When using a server you define bandwidths in the Server Manager.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Brent Seres/ VE3CUS
Sent: 21 September 2021 18:34
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] 2365 Beta won't start the RSPduo. This worked fine in version 2346 #bug

 

I must be doing something wrong, because in my bandwidth menu, with the RSP2,  my maximum bandwidth available is 1 Mhz. That being said, I am running the radio on an old computer running windows 7 in the basement which acts as a server and the actual console is on a new windows 10 machine. Any thoughts? Not a big deal, just wondering. 

 

Brent 

VE3CUS 

 

 

 

 


--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.