Log4OM, SDR-Radio, WSJT-X, Omni-rig


Jack D. Generaux
 

I have been able to use my Hermes-Lite with SDR-Radio, and WSJT-x but unable to get the link through Omni-Rig to Log4OM.  I hvae tried running with Administrator provileges for SDR-Radio, Log4OM, and Omni-rig per Log4OM manual, but always get TS-2000 Port Busy in the external radio window,  I have checked that the Port 11 I am trying to use is not enabled in the Serial Ports SDR-Radio configuration menu.  I have tried bot 57600 and 19200 baudrates.  I have also tried to look at the Omni-Rig with the Omni-Rig Client, but it shows:
Dialog invisible
Rig type: TS-2000
Status: Port is not available
Parameters changed: 7FFFFFFF
Randomly, I get a frequency display in the External Radio window, but don't know why and the message still reports "Port Busy"  I am using the recommended Omni-Rig settings per Simon's guidance on the website.  

Any guidance appreciated -- especially if you have Omni-Rig working with SDR-Radio under WIndows 10.  I may repeat this post on the Log4OM board.
73, Jack (W0FNQ)


martin m3ghe
 

On Sun, Aug 30, 2020 at 09:13 PM, Jack D. Generaux wrote:
Log4OM manual
I don't use Log4OM but surely it's connection to SDR Console should be through the CAT controller section and not through Omni-rig.

--
Martin m3ghe


martin m3ghe
 

I run an external radio via Omni-rig no problem and another program via the CAT controller section all usually runs fine.
Sometimes I get a similar problem to you when using a VSP for the connection. I have to reset the virtual pair and it works again.
If you are using a VSP I suggest you try that.

--
Martin m3ghe


Jack D. Generaux
 

Thanks for replies -- got it to work by disabling the external radio and relying on a virtual serial port pair.


David Jackson
 

Use GridTracker and Cloudlog. Log over UDP / IP. CAT to WSJT-X from SDR-Console. Much easier.