RasPi failing to recognise RTL dongle on start-up


Roger Reeves M0ROJ
 

I know this is not a true SDR-Radio question, but I suspect that there will be many of you who use RasPi in some way for SDR.
My kit is a RasPi 3 and a NooElec NESDR Mini 2, R820T2/RTL2832U SDR dongle.
The problem is that when I start-up the RasPi with the dongle connected its is not recognised.
So leaving the dongle connected I reboot the RasPi and its still not connected.
I remove the dongle - leaving the power connected to the RasPi - and re-insert the dongle, but its still not recognised.
HOWEVER, if I then remove the dongle - still with the power connected to the RasPi - and re-insert it, BINGO!, its recognised and and everything works fine.
As you can appreciate, I cannot tolerate this problem with both the RasPi and dongle remotely connected by wi-fi from the antenna mast, as each time I turn off the power I would have to climb the mast to go through the procedure mentioned above.
And yes, I know I could leave the power connected, but that's not the point.
Does anyone please have a solution for this?
Many thanks in advance.


Joe Puma
 

How many USB devices are you using on your RPI? Is the RTL Dongle connected with a long USB cable? It could be a power issue when booting up if you have many USB devices or if you're using a long cable. 

if it's a USB power issue I believe there is an option that you can set in the boot.INI to give USB max power. You can try that. Otherwise if there's multiple USB devices connected like keyboard and mouse or maybe Wi-Fi dongle's try unplugging everything except your RTL SDR Dongle. 

Joe
KD2NFC 


Sent from my iPhone

On Aug 6, 2017, at 11:16 AM, Roger Reeves <m0roj@...> wrote:

I know this is not a true SDR-Radio question, but I suspect that there will be many of you who use RasPi in some way for SDR.
My kit is a RasPi 3 and a NooElec NESDR Mini 2, R820T2/RTL2832U SDR dongle.
The problem is that when I start-up the RasPi with the dongle connected its is not recognised.
So leaving the dongle connected I reboot the RasPi and its still not connected.
I remove the dongle - leaving the power connected to the RasPi - and re-insert the dongle, but its still not recognised.
HOWEVER, if I then remove the dongle - still with the power connected to the RasPi - and re-insert it, BINGO!, its recognised and and everything works fine.
As you can appreciate, I cannot tolerate this problem with both the RasPi and dongle remotely connected by wi-fi from the antenna mast, as each time I turn off the power I would have to climb the mast to go through the procedure mentioned above.
And yes, I know I could leave the power connected, but that's not the point.
Does anyone please have a solution for this?
Many thanks in advance.


paul newcombe <G6YZC@...>
 

M0ROJ,


As far as  am concerned a good thread to have on the SDR page as I am sure there are many of us who would like to run a RTL with a RASPi remote but have no idea where to start other than Google.  So IMO, and let's face it in my world that is the only one that matters, I am happy to see SDR RasPi infor show up here.


Paul

N2EME




From: SDR-Radio@groups.io <SDR-Radio@groups.io> on behalf of Joe Puma <kd2nfc@...>
Sent: Sunday, August 6, 2017 4:26 PM
To: SDR-Radio@groups.io
Subject: Re: [SDR-Radio] RasPi failing to recognise RTL dongle on start-up
 
How many USB devices are you using on your RPI? Is the RTL Dongle connected with a long USB cable? It could be a power issue when booting up if you have many USB devices or if you're using a long cable. 

if it's a USB power issue I believe there is an option that you can set in the boot.INI to give USB max power. You can try that. Otherwise if there's multiple USB devices connected like keyboard and mouse or maybe Wi-Fi dongle's try unplugging everything except your RTL SDR Dongle. 

Joe
KD2NFC 


Sent from my iPhone

On Aug 6, 2017, at 11:16 AM, Roger Reeves <m0roj@...> wrote:

I know this is not a true SDR-Radio question, but I suspect that there will be many of you who use RasPi in some way for SDR.
My kit is a RasPi 3 and a NooElec NESDR Mini 2, R820T2/RTL2832U SDR dongle.
The problem is that when I start-up the RasPi with the dongle connected its is not recognised.
So leaving the dongle connected I reboot the RasPi and its still not connected.
I remove the dongle - leaving the power connected to the RasPi - and re-insert the dongle, but its still not recognised.
HOWEVER, if I then remove the dongle - still with the power connected to the RasPi - and re-insert it, BINGO!, its recognised and and everything works fine.
As you can appreciate, I cannot tolerate this problem with both the RasPi and dongle remotely connected by wi-fi from the antenna mast, as each time I turn off the power I would have to climb the mast to go through the procedure mentioned above.
And yes, I know I could leave the power connected, but that's not the point.
Does anyone please have a solution for this?
Many thanks in advance.


Jayson Bucknell
 

I use two on a Rpi 3 connected to a powered usb hub. If there's a TCXO I would suspect power drain. Also I've killed a couple cheaper ones with a DC short to the antenna. Things work but heat up fast and fail. Blocking capacitors are good!

73,

Jayson
AA7NM

From: "paul newcombe" <G6YZC@...>
To: SDR-Radio@groups.io
Sent: Sunday, August 6, 2017 1:46:35 PM
Subject: Re: [SDR-Radio] RasPi failing to recognise RTL dongle on start-up

M0ROJ,


As far as  am concerned a good thread to have on the SDR page as I am sure there are many of us who would like to run a RTL with a RASPi remote but have no idea where to start other than Google.  So IMO, and let's face it in my world that is the only one that matters, I am happy to see SDR RasPi infor show up here.


Paul

N2EME




From: SDR-Radio@groups.io <SDR-Radio@groups.io> on behalf of Joe Puma <kd2nfc@...>
Sent: Sunday, August 6, 2017 4:26 PM
To: SDR-Radio@groups.io
Subject: Re: [SDR-Radio] RasPi failing to recognise RTL dongle on start-up
 
How many USB devices are you using on your RPI? Is the RTL Dongle connected with a long USB cable? It could be a power issue when booting up if you have many USB devices or if you're using a long cable. 

if it's a USB power issue I believe there is an option that you can set in the boot.INI to give USB max power. You can try that. Otherwise if there's multiple USB devices connected like keyboard and mouse or maybe Wi-Fi dongle's try unplugging everything except your RTL SDR Dongle. 

Joe
KD2NFC 


Sent from my iPhone

On Aug 6, 2017, at 11:16 AM, Roger Reeves <m0roj@...> wrote:

I know this is not a true SDR-Radio question, but I suspect that there will be many of you who use RasPi in some way for SDR.
My kit is a RasPi 3 and a NooElec NESDR Mini 2, R820T2/RTL2832U SDR dongle.
The problem is that when I start-up the RasPi with the dongle connected its is not recognised.
So leaving the dongle connected I reboot the RasPi and its still not connected.
I remove the dongle - leaving the power connected to the RasPi - and re-insert the dongle, but its still not recognised.
HOWEVER, if I then remove the dongle - still with the power connected to the RasPi - and re-insert it, BINGO!, its recognised and and everything works fine.
As you can appreciate, I cannot tolerate this problem with both the RasPi and dongle remotely connected by wi-fi from the antenna mast, as each time I turn off the power I would have to climb the mast to go through the procedure mentioned above.
And yes, I know I could leave the power connected, but that's not the point.
Does anyone please have a solution for this?
Many thanks in advance.


Christos SV1EIA
 

It looks like a power issue, try to use a higher amperage 5V PSU for the RPi, 4-5Amps maybe.

73,
Christos SV1EIA