Running Headless


Mike German
 

I have configured my mini in the shack to run headless and access it remotely with Teamviewer to overcome monitor RFI.  I run 3 SDRs and connect the auidio output via VACs to Spectrum Lab and record the data.  When I disconnect from Teamviewer and the mini is running alone, noise starts immediately on all channels and stops when I reconnect.  Audio monitoring is disabled on Teamviewer.

I suspect Windows 10 may be doing something.  Has anyone got any ideas? 


Matthias Bopp
 

Hi Mike,

 

I am running a Intel NUC running Windows 10 with a LimeSDR connected to it, sometimes also a Pluto SDR.

 

I access the NUC by the software vnc and transfer the audio (RX and TX) using the software IP-Sound.

 

Works fine. I have not had a keyboard/mouse/display at the NUC for quite some time.

 

Kind regards

 

Matthias

 

www.dd1us.de

 

Von: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> Im Auftrag von Mike German via Groups.Io
Gesendet: Mittwoch, 13. Februar 2019 17:23
An: main@SDR-Radio.groups.io
Betreff: [SDR-Radio] Running Headless

 

I have configured my mini in the shack to run headless and access it remotely with Teamviewer to overcome monitor RFI.  I run 3 SDRs and connect the auidio output via VACs to Spectrum Lab and record the data.  When I disconnect from Teamviewer and the mini is running alone, noise starts immediately on all channels and stops when I reconnect.  Audio monitoring is disabled on Teamviewer.

I suspect Windows 10 may be doing something.  Has anyone got any ideas? 


Mike German
 

Hi Mathias,
Do you use VACs?

Regards
Mike


Matthias Bopp
 

Hi Mike,

Yes.

Regards

Matthias

Von: Mike German via Groups.Io
Gesendet: Mittwoch, 13. Februar 2019 18:36
An: main@SDR-Radio.groups.io
Antwort an: main@SDR-Radio.groups.io
Betreff: Re: [SDR-Radio] Running Headless

Hi Mathias,
Do you use VACs?

Regards
Mike


Mike German
 

Hi Mathias,
 Sounds promising. 

Do you connect with the controlling computer intermittently or continuously?  
Which VNC do you use?

Regards
Mike


Matthias Bopp
 

Hi Mike,

 

My Intel NUC will be in my outdoorunit (ODU) behind the dish for Eshail.

 

I can switch it on and off remotely (I built an IP controlled switch box).

 

When switched on IP-Sound and vnc and SDR-Radio are automatically loaded.

 

IP-Sound is running continuously on my Shack computer.

 

Whenever I want to access the NUC from my PC in my shack I just have to start the vnc viewer in the shack and have access to the NUC at the EsHail dish.

 

Very soon there will be a new version of SDR-Radio supporting the Lime-SDR in fullduplex mode.

 

Thus, I can operate SSB from the shack via the LAN network to my ODU.

 

The LimeSDR is also supporting DATV-Express, thus I will be able to also use the same setup to transmit and receive the DATV signals to/from EsHail-2.

 

I am using VNC from www.realvnc.com

 

Kind regards

 

Matthias

 

www.dd1us.de

 

 

Von: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> Im Auftrag von Mike German via Groups.Io
Gesendet: Mittwoch, 13. Februar 2019 20:37
An: main@SDR-Radio.groups.io
Betreff: Re: [SDR-Radio] Running Headless

 

Hi Mathias,
 Sounds promising. 

Do you connect with the controlling computer intermittently or continuously?  
Which VNC do you use?

Regards
Mike


Bjarne Mjelde
 

I very much doubt that Teamviewer is to blame. I used Tv myself for many years before shifting to Splashtop. And I find it hard to believe that Win10 is to blame. I use Win10-64 Pro on all my four headless remote-controlled PCs, two of them with the latest update (1809). No issues. The symptom you describe is a mystery to me though.
--
Bjarne Mjelde
arcticdx.blogspot.com
Remote rx: arcticsdr.proxy.kiwisdr.com:8073/


Mike German
 

Hi Bjarne,

Same OS as I have.  Yes it's got me stumped, hence my posting here.  Clutching at straws I thought they may be some Windows audio setting that is wrong. I use ASIO4All drivers.

Regards
Mike