LimeSDR not working in sdr-radio console v3


Philip Hahn
 

Hello,

 I have a LimeSDR that doesn't work with sdr-radio console v3. It does work with GNURadio, Pothos and GQRX on the same Windows machine, so I'm confident the Windows driver is correct. 

 When I go to select radio, the software does successfully search and find my LimeSDR. However when I start, the program hangs for about 10 seconds and then I get no spectrum/waterfall. I'm fairly confident I have the program installed/configured properly because I can use an RTLSDR just fine (and in the past I've used a HackRF without issue).

 The machine is a recent i7 however it is a laptop with an intel graphics card. It is plugged in with the LimeSDR as the only perhiperal. 

 Let me know what additional information I can provide or any suggestions. Thanks,

philip hahn


Simon Brown
 

Hi,

 

http://www.sdr-radio.com/Support : A screenshot and logfile would help.

 

What bandwidth are you selecting when you start the LimeSDR? What type of Lime is it – standard or Mini?

 

Simon Brown, G4ELI

 

www.dxgalaxy.com
www.sdr-radio.com
www.sdr-satellites.com

 

 

From: main@SDR-Radio.groups.io [mailto:main@SDR-Radio.groups.io] On Behalf Of Philip Hahn
Sent: 16 February 2018 20:09
To: main@SDR-Radio.groups.io
Subject: [SDR-Radio] LimeSDR not working in sdr-radio console v3

 

Hello,

 

 I have a LimeSDR that doesn't work with sdr-radio console v3. It does work with GNURadio, Pothos and GQRX on the same Windows machine, so I'm confident the Windows driver is correct. 

 

 When I go to select radio, the software does successfully search and find my LimeSDR. However when I start, the program hangs for about 10 seconds and then I get no spectrum/waterfall. I'm fairly confident I have the program installed/configured properly because I can use an RTLSDR just fine (and in the past I've used a HackRF without issue).

 

 The machine is a recent i7 however it is a laptop with an intel graphics card. It is plugged in with the LimeSDR as the only perhiperal. 

 

 Let me know what additional information I can provide or any suggestions. Thanks,

 

philip hahn


Philip Hahn
 

Hi Simon,

 It is a LimeSDR 1.4.

 I put the screenshot, the sdr console log, and the LimeSDR log in my google drive:


 I didn't see any specific errors in the log other than CUDA drivers not being present. 

 Thanks,

philip


Simon Brown
 

Well,

 

Please always add attachments to e-mails, that way they are archived here.

 

The Lime is running, returning data, using CPU. Radio is tuned to ~729 MHz. Just nothing on the waterfall. It’s not using the CYUDA, it’s using the CPU but that’s fine.

 

Sorry – can’t see what’s wrong without comparing the logfile / Lime to my own.

 

Simon Brown, G4ELI

 

www.dxgalaxy.com
www.sdr-radio.com
www.sdr-satellites.com

 

 

From: main@SDR-Radio.groups.io [mailto:main@SDR-Radio.groups.io] On Behalf Of Philip Hahn
Sent: 17 February 2018 00:44
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] LimeSDR not working in sdr-radio console v3

 

Hi Simon,

 

 It is a LimeSDR 1.4.

 

 I put the screenshot, the sdr console log, and the LimeSDR log in my google drive:

 

 

 I didn't see any specific errors in the log other than CUDA drivers not being present. 

 

 Thanks,

 

philip


Simon Brown
 

Thinks: Antenna selection? Add visual gain? Maybe there’s a weak signal down there…

 

 

From: main@SDR-Radio.groups.io [mailto:main@SDR-Radio.groups.io] On Behalf Of Simon Brown
Sent: 17 February 2018 07:12
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] LimeSDR not working in sdr-radio console v3

 

Well,

 

Please always add attachments to e-mails, that way they are archived here.

 

The Lime is running, returning data, using CPU. Radio is tuned to ~729 MHz. Just nothing on the waterfall. It’s not using the CYUDA, it’s using the CPU but that’s fine.

 

Sorry – can’t see what’s wrong without comparing the logfile / Lime to my own.

 

Simon Brown, G4ELI

 

www.dxgalaxy.com
www.sdr-radio.com
www.sdr-satellites.com

 

 

From: main@SDR-Radio.groups.io [mailto:main@SDR-Radio.groups.io] On Behalf Of Philip Hahn
Sent: 17 February 2018 00:44
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] LimeSDR not working in sdr-radio console v3

 

Hi Simon,

 

 It is a LimeSDR 1.4.

 

 I put the screenshot, the sdr console log, and the LimeSDR log in my google drive:

 

 

 I didn't see any specific errors in the log other than CUDA drivers not being present. 

 

 Thanks,

 

philip


Philip Hahn
 

If I tune up to 100MHz you would anticipate seeing FM radio (without a FM trap, I see reflections all over the place). No trap, FM optimal antenna:



For posterity I attached logs (sorry I didn't do that in the first place most mailing lists don't have the bandwidth. nice!)

The thing that gives me pause is the delay in startup - maybe 8 seconds or so where the GUI is froze, after selecting "start", whereas it is instant with other radios. If I record the RF (Rec/Playback->Data::Record->Record) after the header the binary content of the file is all zeros.



Not sure what other useful information I can provide. If there is something let me know. Thanks,

philip




On Fri, Feb 16, 2018 at 11:38 PM, Simon Brown <simon@...> wrote:

Thinks: Antenna selection? Add visual gain? Maybe there’s a weak signal down there…

 

 

From: main@SDR-Radio.groups.io [mailto:main@....io] On Behalf Of Simon Brown
Sent: 17 February 2018 07:12


To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] LimeSDR not working in sdr-radio console v3

 

Well,

 

Please always add attachments to e-mails, that way they are archived here.

 

The Lime is running, returning data, using CPU. Radio is tuned to ~729 MHz. Just nothing on the waterfall. It’s not using the CYUDA, it’s using the CPU but that’s fine.

 

Sorry – can’t see what’s wrong without comparing the logfile / Lime to my own.

 

Simon Brown, G4ELI

 

www.dxgalaxy.com
www.sdr-radio.com
www.sdr-satellites.com

 

 

From: main@SDR-Radio.groups.io [mailto:main@....io] On Behalf Of Philip Hahn
Sent: 17 February 2018 00:44
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] LimeSDR not working in sdr-radio console v3

 

Hi Simon,

 

 It is a LimeSDR 1.4.

 

 I put the screenshot, the sdr console log, and the LimeSDR log in my google drive:

 

 

 I didn't see any specific errors in the log other than CUDA drivers not being present. 

 

 Thanks,

 

philip