Date   

Re: RSP2 Play crashes software

Max
 

Simon, do realise you will want the error log if I can recreate the issue, but no time now. Maybe later if I get further.

73

Max


Re: RSP2 Play crashes software

Max
 

Hi Simon

Just tried to provoke it again by rapidly changing IF gain settings (not in any specific order). Unfortunately the behavior is back, crashed straight away. I have not had any such crashes prior to this version. Also for information RSP2 is powered from a powered USB 3.0 hub. Have not had time to check power to hub. Will do so later and report back.

Bizarrely, it's only happening with me when I change IF gain setting on 3.7 MHz after recalling HF favourites group preset and selecting that particular RX from the RX matrix. I am guessing there is some combination of settings I have on this RX stored preset that is not on the other RXs, but may be barking completely up the wrong tree here so will say no more until had chance to take a very careful look to see what may be provoking it. What makes me think this is I recalled favourites group, selected the RX set to 14 MHz, direct freq input to 3.7MHz, rapidly changed IF gain, no crash. Recalled favourites group again, selected the 3.7MHz RX, changed IF gain preset, crashed immediately again..... hence my theory.

In the meantime Simon is there a link to the USB issue anywhere?

Max


Set CW Sidetone Freq?

Hasan Schiers N0AN
 

How do you change/set the CW sidetone on Rx?
It  is too low, I'd like to  have it about 800 Hz and it looks like it is about 500 or 600.

In other words, when I put the SDR in CW mode and select a narrow filter, like 100 Hz, I want to be able to hear a center freq tone of 800 Hz, not 500 like it is now.

I've looked all over settings and can'd find any setting that resembles choosing your own CW sidetone freq on Rx

TIA, 73, N0AN
Hasan


Re: ANAN - Testing

Andrew Avery
 

Hi Simon, I have an Anan 100D which I am happy to upgrade to Protocol 2 to play/test with your software?

Did you ever build Puresignal support btw?

de Andy

VK2JXA 

vk2jxa [at] wia [dot] org [dot] au


GMDSS: Another use for multi-channel reception

Nils Schiffhauer
 

Hi - it seems that some user of V3 are still asking: For what should I use up to 24 demodulators of this software?

One answer is simple: to decode up to 24 different channels in parallel! One application is HFDL, one other the GMDSS system of ship-shore and shore-ship communications on six main HF channels. After the HFDL net, this one seems to be the one with the second-most data activity on HF and always worthwhile to have a look on.

As modern SDRs allow for wide HF bandwidths, such a setup may receive all those HF GMDSS channels from 2177 up to 16'804.5 kHz in parallel.
They can be decoded also in parallel by software like YaDD and MultiPSK.

As you get altogether about 5000 messages/24 h, it is a good idea to collect all the decoded data streams into one database.

Mike Simpson has recently done exactly done this: his "GMDSS-Display" module of his free Display Launcher software listens to the decoded output of up to seven MultiPSK instances and presents all the information in one neatly arranged database:
https://www.rstools.info/downloads-2.html

I wrote a short hint with some results on my webpage:
https://dk8ok.org/

73 Nils

--
dk8ok.org


Re: Extend the database manager v3 with a notes column?

Nils Schiffhauer
 

... well, and may I add one completely empty database file. in which all relevant data can be transferred just with a mouse click into?

This may work as a super comfortable logbook ...

Thanks & 73: Nils, DK8OK


Am 08.10.2018 um 10:45 schrieb Kees van Engelen:
Hi Simon,

Can the the database layout be extended with a notes-column, just like the v2  version?
The tracking of the v3  database is correct opposite to the version 2 who doesn't update that good.

I use the notes column for decoding information when listening to data stations.

Thank you.

73
Kees
PA3KVE

-- 
dk8ok.org


Extend the database manager v3 with a notes column?

Kees van Engelen
 

Hi Simon,

Can the the database layout be extended with a notes-column, just like the v2  version?
The tracking of the v3  database is correct opposite to the version 2 who doesn't update that good.

I use the notes column for decoding information when listening to data stations.

Thank you.

73
Kees
PA3KVE


Re: SDR-Radio v2 : Frequency database tracking not accurate

Kees van Engelen
 
Edited

Sorry, already asked that previous year.
I assume there wasn't time yet to fix :-)

https://sdr-radio.groups.io/g/main/topic/5823598#35952


Re: RSP2 Play crashes software

Simon Brown
 

Max,

 

Really sounds like USB power issues to me.

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Max via Groups.Io
Sent: 08 October 2018 09:05
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] RSP2 Play crashes software

 

Had same problem couple of nights ago, and freeze was reliably caused by changing the IF gain control, and after much less than 10 mins, but next day after full reboot was all OK again so will keep an eye.

Max


Re: RSP2 Play crashes software

Max
 

Had same problem couple of nights ago, and freeze was reliably caused by changing the IF gain control, and after much less than 10 mins, but next day after full reboot was all OK again so will keep an eye.

Max


Re: bladeRF 2.0 In Action

Simon Brown
 

Matt,

 

It’ll be switched off when the software starts the radio I expect. I’ll try to add this tomorrow or Wednesday, I forgot Bias-T .

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of mattdsmith228@...
Sent: 08 October 2018 03:20
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] bladeRF 2.0 In Action

 

Is it possible to add setting to turn off the Bias-T within SDR Console, i've tried turning it on via BladeRF-cli then starting SDRC but it turns off once i do.

Thanks!

Matt


Re: BladeRF 2.0 Enabling Bias-T

Simon Brown
 

No,

 

It’s on my list, maybe this week.

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of mattdsmith228@...
Sent: 08 October 2018 03:25
To: main@SDR-Radio.groups.io
Subject: [SDR-Radio] BladeRF 2.0 Enabling Bias-T

 

Is there currently a way to enable the Bias-T LNA within SDRC, I've tried enabling it with BladeRF-cli then starting SDRC but it just turns itself off.

Thanks
Matt


This Week

Simon Brown
 

Hi All,

 

This week:

  • Builders are here laying a new drive.
  • I’ll be on the roof putting up a 40m antenna.
  • I’ll be tidying up the attic – amazing how much junk I have collected over the years.
  • I’ll get the v3.0.4 code tested with the ANAN 8000DLE (I have new firmware to test).
  • On Friday I’m off to the RSGB Convention.

 

If you’re visiting the RSGB convention look out for a scruffy programmer-type, that’ll be me 😊 .

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 


Re: SDR Console V3 GUI very slow #sdrconsolev3

Simon Brown
 

Todd,

 

My thoughts:

 

Start SDR Console, don’t start a radio. Is the UI still slow? If you move the mouse over the screen do the cursor bars and frequency popup follow smoothly? If not then this is a video driver update gone wrong.

 

If the sluggish performance only happens when using SDR Console with a radio started then maybe you have a bad USB driver update? I see you are using a RTL Dongle, maybe jdow can help here?

 

This has to be a driver issue, you have more than enough computer power 😊 .

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Simon Brown
Sent: 08 October 2018 06:22
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] SDR Console V3 GUI very slow #sdrconsolev3

 

Todd,

 

You are not forgotten.

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of todd hawley
Sent: 07 October 2018 13:17
To: main@sdr-radio.groups.io
Subject: Re: [SDR-Radio] SDR Console V3 GUI very slow #sdrconsolev3

 

Simon,

 

Try these.


BladeRF 2.0 Enabling Bias-T

mattdsmith228@...
 

Is there currently a way to enable the Bias-T LNA within SDRC, I've tried enabling it with BladeRF-cli then starting SDRC but it just turns itself off.

Thanks
Matt


Re: bladeRF 2.0 In Action

mattdsmith228@...
 

Is it possible to add setting to turn off the Bias-T within SDR Console, i've tried turning it on via BladeRF-cli then starting SDRC but it turns off once i do.

Thanks!

Matt


Tmate 2

stumpfandreas@...
 

Hi all

Does someone have the same problem ?

My ELAD Tmate 2 console connected to my Perseus is working well, but when I turn the VFO the frequency goes back to 0 after some kHz…..

73’s de HB9GCE, Andy

 


SDR ELAD console is working well but when I turn the VFO the Frequency switches to 0 after a while

stumpfandreas@...
 

Hi All Does someone have the same problem ? My ELAD Tmate2 console connected to my Perseus is working well, but when I turn the VFO the frequency goes back to zero after some kHz....... 73's de HB9GCE, Andy 


SDR Console: Freeze on Start

Simon Brown
 

Hi All,

 

If SDR Console freezes when started:

 

 

This way I can find the problem, many thanks.

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 


Re: SDR Console V3 GUI very slow #sdrconsolev3

Simon Brown
 

Todd,

 

You are not forgotten.

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of todd hawley
Sent: 07 October 2018 13:17
To: main@sdr-radio.groups.io
Subject: Re: [SDR-Radio] SDR Console V3 GUI very slow #sdrconsolev3

 

Simon,

 

Try these.

 

On Sun, Oct 7, 2018 at 12:15 AM Simon Brown <simon@...> wrote:

Todd,

 

I can’t read the screenshot. Please *Attach* it so I can read it properly.

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of todd hawley
Sent: 07 October 2018 02:32
To: main@sdr-radio.groups.io
Subject: Re: [SDR-Radio] SDR Console V3 GUI very slow #sdrconsolev3

 

Simon,

 

I've included all the screen shots of my radio config and the cpu and gpu performance and display settings.  I could certainly take screenshots of all the settings tabs if necessary.  Still having the same issue.  Program crashes after 5 or so minutes and the GUI is very sluggish.  If its helpful, it seems the console v2 is still working well.  In the first screenshot the radio is active and is working.  As you can see the "stop", "bandwidth", freq"  etc is grayed out.  This will become available in a few minutes.  In the screenshot of the "set tuner modes," I am direct sampling however the issues I am having are consistent with direct sampling turned off.  As I mentioned before the radio stream doesn't seem choppy, just the GUI and controls.  Another issue I have found is that changing the freq in the top left corner of the screen no longer works.  I can adjust the values but they won't apply.  I can use the direct entry method at the bottom right and I can use the slider at the bottom to bump up a 125khz or whatever i have the span set to at the time.  Like i said this all happened after a system restart and the program was smooth an very responsive before that.  Also I did not mention that I did set the program to run as administrator without any change.  I also reinstalled the program without the mods and the problem persists.  In writing this email I'm also finding that often but not always, the program crashes when I alt-tab from chrome back to the console.  I'm leaning towards this being a windows update issue however I've not been able to find post recently with my issue.  I wish i had some more useful information.  I appreciate your time.

 

Todd      

 

 

 

 

On Mon, Oct 1, 2018 at 1:20 PM Simon Brown <simon@...> wrote:

Yes,

 

Anything you have helps. Every e-mail I write costs time, is a distraction. Let’s see what you have…

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of todd hawley
Sent: 01 October 2018 15:45
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] SDR Console V3 GUI very slow #sdrconsolev3

 

I can provide screenshots. Would you like the main interface and or settings?  


On Sep 29, 2018, at 11:57 PM, Simon Brown <simon@...> wrote:

Logfile is OK.

 

Screenshot?

 

Simon Brown, G4ELI
www.sdr-radio.com

 

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of toddhawley2@...
Sent: 29 September 2018 19:51
To: main@SDR-Radio.groups.io
Subject: [SDR-Radio] SDR Console V3 GUI very slow #sdrconsolev3

 

I've been using SDR Console V3 (3.0.3 build 1263) with a RTL-SDR.COM v3 sdr. I'm also using the rtlsdr++ and Console mods available here https://drive.google.com/drive/folders/0B4ImLhg3WKL5fnhRalBOVU8wVmFma1ZzR25LVEZYR0RBMzBwTFh6M0psbkZOei03ZVBDeTQ
My machine is an I7 5930k with 8 GB Ram, NVIDIA 1080ti and Creative SD X-FI sound card.  The software has been working well until yesterday.  I restarted my computer and the radio would no longer start.  I re-installed the software and mods and though I don't remember having to do this the first time, I had to run the catalog.exe in the SDR Console folder in order to get the radio definition to work.  Once i did this I was able to get the radio to work, even direct sampling.  The audio itself is smooth however the GUI is very slow. The spectrum analyzer and waterfall are updating maybe twice a second at best.  Any interaction with the GUI is delayed by several seconds.  Just changing frequency can up to a minute.  The stop button on the home tab is greyed out so i cannot stop the radio.  Trying to close the program often results in several screen flashes as if its closing and reopening itself.  If i don't close the program and just let it run it will crash in 5-10 minutes. The CPU and GPU usage meters at the bottom of the interface never exceed 10%.  The GPU is closer to 1%.  I tried SDR# and it seems to be working fine so I don't think its my hardware.  I've included my log file.  I could include my settings if there is a settings file somewhere someone could point out.  I would appreciate any suggestions as to how I solve this issue. Thanks.

Attachments: