Date   

Re: Console with Elad S2 not working

George Stein - NJ3H
 

Hello Simon, 

Thanks for your reply. 

I used the Airspy HF+ Discovery and set the waterfall gain tp max and set time stamps on. I wanted to make sure things were working for both the max visual gain and timestamps. 

Then I got out of the Airspy and went to the Elad S2. Nothing. No spectrum or waterfall was displayed, therefore the two items set were not visible since the radio didn't do anything. Just like in the picture again the program froze up when trying to exit. 

I tried a different USB cable to a different port. Still didn't work. 

Again the Elad works with the Elad native software. 

I have deleted the definition and then let Console reload it. No luck. 

Looking in device manager, there is not a listing for Elad.   But as I mentioned the native software works. Shouldn't there be an entry?

So what do you suggest? 

Thanks, 
George 

On Tue, Jun 14, 2022 at 12:48 AM, Simon Brown
<simon@...> wrote:
Let's see whether it's streaming data:

  • Set visual gain to the maximum.
  • Enable timestamps in the waterfall.
If still nothing then we're not getting data - could be USB port. Anyway, try the above first.

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on behalf of George Stein - NJ3H via groups.io <nj3h@...>
Sent: 14 June 2022 07:39
To: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io>
Subject: [SDR-Radio] Console with Elad S2 not working
 
Greetings,

I can not get Console to work with my Elad S2.  I have never had this problem before.  I can get the remote receivers to work and the Airspy Discover+ HF with no problem.

As can be seen in the the attached picture, it looks like the Elad is selected, but no spectrum or waterfall.  when I close out of the program, I get the message that the program could not close properly.

I tried the Elad with its native software and it works fine.

So any ideas what could be going on here?  Let me know if any additional pictures would be helpful.

Thanks,
George, NJ3H
Redmond, Oregon USA

--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Re: Main Receiver DSP Docking to the RHS

Nicholas Shaxted
 

Thanks Gisle, but that is what I tried and it doesn’t work here.

When I drag the DSP window to where I want it and all the arrowed windows appear it allows me to drop it in the correct place, but the whole receive window does not shift and the DSP just sits atop the left-hand edge of the rx window.

The problem is that the DSP has become a floating window (again) and when asking it (very nicely) to become a docked window it pops back over to the right-hand side.

 

 

No matter what I do it seems only to want to dock only to the right-hand side.

It didn’t think it was a bug but merely a simple user error made by a simple user.

 

FWIW The mouse is setup for use left-handed.

 

Nick - g4ogi

For other amusement I have written PTO on both sides at the bottom of a blank piece of A4 paper.

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Gisle Vanem via groups.io
Sent: 14 June 2022 08:43
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] Main Receiver DSP Docking to the RHS

 

Just click and drag the windows from the right to the left.

Mind you, it's a docking window, so it won't dock were you want until the dark-blue hint-area shows up.


Re: Console with Elad S2 not working

Simon Brown
 

Let's see whether it's streaming data:

  • Set visual gain to the maximum.
  • Enable timestamps in the waterfall.
If still nothing then we're not getting data - could be USB port. Anyway, try the above first.

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on behalf of George Stein - NJ3H via groups.io <nj3h@...>
Sent: 14 June 2022 07:39
To: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io>
Subject: [SDR-Radio] Console with Elad S2 not working
 
Greetings,

I can not get Console to work with my Elad S2.  I have never had this problem before.  I can get the remote receivers to work and the Airspy Discover+ HF with no problem.

As can be seen in the the attached picture, it looks like the Elad is selected, but no spectrum or waterfall.  when I close out of the program, I get the message that the program could not close properly.

I tried the Elad with its native software and it works fine.

So any ideas what could be going on here?  Let me know if any additional pictures would be helpful.

Thanks,
George, NJ3H
Redmond, Oregon USA

--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Re: Main Receiver DSP Docking to the RHS

Gisle Vanem
 

Just click and drag the windows from the right to the left.

Mind you, it's a docking window, so it won't dock were you want until the dark-blue hint-area shows up.


Console with Elad S2 not working

George Stein - NJ3H
 

Greetings,

I can not get Console to work with my Elad S2.  I have never had this problem before.  I can get the remote receivers to work and the Airspy Discover+ HF with no problem.

As can be seen in the the attached picture, it looks like the Elad is selected, but no spectrum or waterfall.  when I close out of the program, I get the message that the program could not close properly.

I tried the Elad with its native software and it works fine.

So any ideas what could be going on here?  Let me know if any additional pictures would be helpful.

Thanks,
George, NJ3H
Redmond, Oregon USA


Main Receiver DSP Docking to the RHS

Nicholas Shaxted
 

Ok dear wise heads,

I installed “SDR-Radio V3.1, 64-bit, 2022-04-12_1245” this morning and when I started it I asked it to remove the DSP panel so that I has only the rx window displaying.

Normally the DSP panel sits to the left of the screen so imagine my surprise when I re-enabled it and it docked over the right-hand side (as per attached screenshot).

I took this as a challenge to find out where the left/right switch was but after rather far too long playing I have decided to give up.

 

The question is a simple one. How do I persuade SDR-Console to display the DSP panel on the left-hand side of the Console window?

I have tried choccy treats and pictures of cats..but decided I have missed something pretty obvious,

Another cup of finely brewed tea methinks whilst I cogitate further.

 

Nick – g4ogi


Re: WR-G31DDC Help

Simon Brown
 

Hi,

The logfile is selected from the ribbon bar's Tools pane, it is displayed in the default text file viewer. The logfile contains copious diagnostic information, in the event of a problem save the logfile to a text file.
www.sdr-radio.com


From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on behalf of Jim Lill via groups.io <jim@...>
Sent: 13 June 2022 23:58
To: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io>
Subject: Re: [SDR-Radio] WR-G31DDC Help
 

Thanks Don...

It was installed in both cases and the LED flash pattern suggests it's there OK

-Jim

On 6/13/22 18:42, Don Moman VE6JY wrote:

You haven't mentioned installing the driver...  Mine shows up as a G31DDC under Radio Receivers in Device Manager.  

On Mon, Jun 13, 2022 at 4:05 PM Jim Lill <jim@...> wrote:
I've had my unit for some time but haven't used it in a few months. I
just tried using it with several W10 boxes with both the supplied
program and SDR-Console, both of which worked previously but I now have
issues.  Of course in the interim Microsoft has been updating W10.  When
I tried to use the supplied program, it must see that there is a
Receiver there as the UI comes then goes off.   When I try to use
SDR-Console, it looks good but when I start the receiver no actual
receive. Again, both circumstances worked fine the last time but no-go
now.  What am I overlooking.

73

Jim

WA2ZKD







--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Re: WR-G31DDC Help

Jim Lill
 

Thanks Don...

It was installed in both cases and the LED flash pattern suggests it's there OK

-Jim

On 6/13/22 18:42, Don Moman VE6JY wrote:

You haven't mentioned installing the driver...  Mine shows up as a G31DDC under Radio Receivers in Device Manager.  

On Mon, Jun 13, 2022 at 4:05 PM Jim Lill <jim@...> wrote:
I've had my unit for some time but haven't used it in a few months. I
just tried using it with several W10 boxes with both the supplied
program and SDR-Console, both of which worked previously but I now have
issues.  Of course in the interim Microsoft has been updating W10.  When
I tried to use the supplied program, it must see that there is a
Receiver there as the UI comes then goes off.   When I try to use
SDR-Console, it looks good but when I start the receiver no actual
receive. Again, both circumstances worked fine the last time but no-go
now.  What am I overlooking.

73

Jim

WA2ZKD







Re: WR-G31DDC Help

Don Moman VE6JY
 

You haven't mentioned installing the driver...  Mine shows up as a G31DDC under Radio Receivers in Device Manager.  

On Mon, Jun 13, 2022 at 4:05 PM Jim Lill <jim@...> wrote:
I've had my unit for some time but haven't used it in a few months. I
just tried using it with several W10 boxes with both the supplied
program and SDR-Console, both of which worked previously but I now have
issues.  Of course in the interim Microsoft has been updating W10.  When
I tried to use the supplied program, it must see that there is a
Receiver there as the UI comes then goes off.   When I try to use
SDR-Console, it looks good but when I start the receiver no actual
receive. Again, both circumstances worked fine the last time but no-go
now.  What am I overlooking.

73

Jim

WA2ZKD







WR-G31DDC Help

Jim Lill
 

I've had my unit for some time but haven't used it in a few months. I just tried using it with several W10 boxes with both the supplied program and SDR-Console, both of which worked previously but I now have issues.  Of course in the interim Microsoft has been updating W10.  When I tried to use the supplied program, it must see that there is a Receiver there as the UI comes then goes off.   When I try to use SDR-Console, it looks good but when I start the receiver no actual receive. Again, both circumstances worked fine the last time but no-go now.  What am I overlooking.

73

Jim

WA2ZKD


Re: Is anyone familiar with Xilinx Vivado software to JTAG a PlutoSDR??

Chris Wilson
 

Hello Don,

Monday, June 13, 2022

Yes, tried tah and have used it several times in the past, but dfu-util can't even see it. Analog Devices say JTAG is the only fix now, but they do seem sure JTAG can fix it...

Thanks for the reply Don, appreciated.


Best regards,
Chris 2E0ILY mailto:chris@...


DW>
DW>
DW> Have you tried DFU mode?
DW>
DW>

DW> https://ez.analog.com/adieducation/university-program/f/q-a/119707/bricked-adalm-pluto
DW>
DW>
DW>
DW> Bricked ADALM-PLUTO - Q&A - Virtual Classroom for ADI University
DW> Program - EngineerZone - Analog Devices
DW> someone on twitter asked: Just got my PlutoSDR, tried updating
DW> the firmware to 0.31, bricked it. Ran dfu-util to unbrick it, says
DW> it's done but it's still bricked
DW> ez.analog.com
DW>
DW> 73's
DW>
DW>
DW> Don W.
DW> KD4APP
DW>
DW>
DW>

DW>
DW> From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on
DW> behalf of Chris Wilson via groups.io <chris@...>
DW> Sent: Monday, June 13, 2022 8:47 AM
DW> To: main@sdr-radio.groups.io <main@sdr-radio.groups.io>
DW> Subject: [SDR-Radio] Is anyone familiar with Xilinx Vivado software to JTAG a PlutoSDR??
DW>
DW>
DW> 13 June 2022
DW>
DW>
DW> I have a totally bricked Pluto SDR that dfu-util fails to see. I
DW> am looking for someone familiar with this obtuse software from
DW> Xilinx to resurrect it via JTAG. I have the adepter board from
DW> Analog Devices and the Digilent board and cable.
DW>
DW> If anyone wants the full version please see below, it seems few
DW> people have used the JTAG access and documented it well. Here's
DW> hoping someone here knows what I have done wrong...
DW>
DW>
DW> I have bricked my Pluto and Analog Devices seem sure that by
DW> using JTAG it can be resurrected. However, using all the free time
DW> I can possibly spare I have hit a brick(ed) wall. I am in
DW> desperate need of someone who understands this sort of thing and
DW> Google searching brings up your good self as obviously
DW> extraordinarily knowledgeable on the under bonnet workings of the Pluto.
DW>
DW> If you have time and inclination to read the below, this is where I find myself:
DW>
DW> Analog Devices dfu-util does not see it, and it's now in a state
DW> where just one LED is lit, and it's very dim.
DW>
DW> An Analog Devices tech help forum suggestion (by an AD engineer)
DW> was that the only fix was using JTAG and I would need both the
DW> interface box from AD and a cable and dongle from Digilent (sp?).
DW>
DW> I purchased those and followed the instructions here after going
DW> through hoops to find and download a legacy version of Xilnx
DW> programming software that still supported the XMD Console.
DW>
DW> https://wiki.analog.com/university/tools/pluto/devs/fpga
DW>
DW> This stuff sees my Pluto and will communicate with it but I am now stuck at where I am below.
DW>
DW> I have come back to this after getting a headache and getting nowhere in the last week ;)
DW>
DW>
DW> I am finding on Google others have issues with forcing a target,
DW> but maybe I am way off course. Below I copy paste the results of
DW> trying to run the run.tcl file AD supply in a zip with other
DW> files. I set the Xilinx workspace to C:/workspace and unzipped the
DW> supplied files in there, and before trying to run the run.tcl I
DW> ensured I was in the workspace directory. Does this give a clues
DW> as to what's gone wrong please? Even when the none running core is
DW> running the same happens. To get it running I have to power down
DW> the PlutoSDR and power it up again.
DW>
DW> @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
DW>
DW> ****** Xilinx System Debugger (XSDB) v2014.1
DW> **** Build date : Apr 4 2014-14:07:09
DW> ** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.
DW>
DW>
DW> Got $XILINX_SDK: C:/XilinxSDK/SDK/2014.1
DW>
DW> xsdb% connect -host localhost -port 3121 tcfchan#0
DW> ::tcfchan#0
DW> xsdb% targets
DW> 1 xc7z010
DW> 2 APU
DW> 3 ARM Cortex-A9 MPCore #0 (Stopped: Suspended)
DW> 4 ARM Cortex-A9 MPCore #1 (Running)
DW> xsdb% target 1
DW> xsdb% targets
DW> 1* xc7z010
DW> 2 APU
DW> 3 ARM Cortex-A9 MPCore #0 (Stopped: Suspended)
DW> 4 ARM Cortex-A9 MPCore #1 (Running)
DW> xsdb% cd C:/workspace
DW> xsdb% dir
DW> Volume in drive C has no label.
DW> Volume Serial Number is D080-C2AD
DW>
DW> Directory of C:\workspace
DW>
DW> 11/06/2022 09:50 <DIR> .
DW> 11/06/2022 09:50 <DIR> ..
DW> 10/06/2022 10:31 <DIR> .metadata
DW> 20/08/2021 13:12 31,486 ps7_init.tcl
DW> 10/06/2022 12:28 <DIR> RemoteSystemsTempFiles
DW> 03/03/2017 08:56 257 run.tcl
DW> 11/06/2022 10:11 567 SDK.log
DW> 20/08/2021 13:12 964,144 system_top.bit
DW> 20/08/2021 13:13 448,084 u-boot.elf
DW> 5 File(s) 1,444,538 bytes
DW> 4 Dir(s) 422,109,966,336 bytes free
DW> xsdb% xmd source -tcl run.tcl
DW>
DW> ****** Xilinx Microprocessor Debugger (XMD) EngineExecuting user script : run.tcl
DW>
DW> JTAG chain configuration
DW> --------------------------------------------------
DW> Device ID Code IR Length Part Name
DW> 1 4ba00477 4 arm_dap
DW> 2 13722093 6 xc7z010
DW>
DW> --------------------------------------------------
DW> Enabling extended memory access checks for Zynq.
DW> Writes to reserved memory are not permitted and reads return 0.
DW> To disable this feature, run "debugconfig -memory_access_check disable".
DW>
DW> --------------------------------------------------
DW>
DW> CortexA9 Processor Configuration
DW> -------------------------------------
DW> Version.............................0x00000003
DW> User ID.............................0x00000000
DW> No of PC Breakpoints................6
DW> No of Addr/Data Watchpoints.........4
DW>
DW> Connected to "arm" target. id = 64
DW> Starting GDB server for "arm" target (id = 64) at TCP port no 1234
DW> Processor stopped
DW>
DW> Error Executing User Script : run.tcl
DW> Error :: ERROR: No Elf file associated with target
DW>
DW> ****** XMD v2014.1 (64-bit)
DW> **** SW Build 881834 on Fri Apr 4 14:06:19 MDT 2014
DW> ** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.
DW>
DW> xsdb%
DW>
DW>
DW> @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
DW>
DW>
DW> I link to the bootstrap zip file from AD that I am using, I
DW> suspect, but what do I know, that I need to somehow associate the
DW> u-boot.elf file with the Pluto, but at this point I'm stuck. Any
DW> help would be most appreciated. OS is Windows 10 64 bit Pro and I
DW> have tried using Xilinx SDK 2014.1 and Vivado Lab 2017.3
DW>
DW> Current versions of Xilinx fail to load at all on this PC, the
DW> installer fails to complete, but AD tell me I need a legacy
DW> version anyway, that supports XMD as that is what they based the run.tcl format on.
DW>
DW> The JTAG bootstrap files are here :
DW>
DW> http://www.chriswilson.tv/plutosdr-jtag-bootstrap-v0.34(1).zip
DW>
DW> Thanks for any insight!
DW>
DW>
DW>
DW> --
DW>
DW>
DW> Best regards,
DW> Chris mailto:chris@...
DW>
DW>
DW>
DW>
DW>
DW>
DW>
DW>


Re: Is anyone familiar with Xilinx Vivado software to JTAG a PlutoSDR??

Don Woodward
 

Have you tried DFU mode?

someone on twitter asked: Just got my PlutoSDR, tried updating the firmware to 0.31, bricked it. Ran dfu-util to unbrick it, says it's done but it's still bricked
ez.analog.com

73's

Don W.
KD4APP


From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on behalf of Chris Wilson via groups.io <chris@...>
Sent: Monday, June 13, 2022 8:47 AM
To: main@sdr-radio.groups.io <main@sdr-radio.groups.io>
Subject: [SDR-Radio] Is anyone familiar with Xilinx Vivado software to JTAG a PlutoSDR??
 
13 June 2022


I have a totally bricked Pluto SDR that dfu-util fails to see. I am looking for someone familiar with this obtuse software from Xilinx to resurrect it via JTAG. I have the adepter board from Analog Devices and the Digilent board and cable.

If anyone wants the full version please see below, it seems few people have used the JTAG access and documented it well. Here's hoping someone here knows what I have done wrong...


I have bricked my Pluto and Analog Devices seem sure that by using JTAG it can be resurrected. However, using all the free time I can possibly spare I have hit a brick(ed) wall. I am in desperate need of someone who understands this sort of thing and Google searching brings up your good self as obviously extraordinarily knowledgeable on the under bonnet workings of the Pluto.

If you have time and inclination to read the below,  this is where I find myself:

Analog Devices dfu-util does not see it, and it's now in a state where just one LED is lit, and it's very dim.

An Analog Devices tech help forum suggestion (by an AD engineer) was that the only fix was using JTAG and I would need both the interface box from AD and a cable and dongle from Digilent (sp?).

I purchased those and followed the instructions here after going through hoops to find and download a legacy version of Xilnx programming software that still supported the XMD Console.

https://wiki.analog.com/university/tools/pluto/devs/fpga

This stuff sees my Pluto and will communicate with it but I am now stuck at where I am below.

I have come back to this after getting a headache and getting nowhere in the last week ;)


I am finding on Google others have issues with forcing a target, but maybe I am way off course. Below I copy paste the results of trying to run the run.tcl file AD supply in a zip with other files. I set the Xilinx workspace to C:/workspace and unzipped the supplied files in there, and before trying to run the run.tcl I ensured I was in the workspace directory. Does this give a clues as to what's gone wrong please? Even when the none running core is running the same happens. To get it running I have to power down the PlutoSDR and power it up again.

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

****** Xilinx System Debugger (XSDB) v2014.1
**** Build date : Apr 4 2014-14:07:09
** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.


Got $XILINX_SDK: C:/XilinxSDK/SDK/2014.1

xsdb% connect -host localhost -port 3121 tcfchan#0
::tcfchan#0
xsdb% targets
1 xc7z010
2 APU
3 ARM Cortex-A9 MPCore #0 (Stopped: Suspended)
4 ARM Cortex-A9 MPCore #1 (Running)
xsdb% target 1
xsdb% targets
1* xc7z010
2 APU
3 ARM Cortex-A9 MPCore #0 (Stopped: Suspended)
4 ARM Cortex-A9 MPCore #1 (Running)
xsdb% cd C:/workspace
xsdb% dir
Volume in drive C has no label.
Volume Serial Number is D080-C2AD

Directory of C:\workspace

11/06/2022 09:50 <DIR> .
11/06/2022 09:50 <DIR> ..
10/06/2022 10:31 <DIR> .metadata
20/08/2021 13:12 31,486 ps7_init.tcl
10/06/2022 12:28 <DIR> RemoteSystemsTempFiles
03/03/2017 08:56 257 run.tcl
11/06/2022 10:11 567 SDK.log
20/08/2021 13:12 964,144 system_top.bit
20/08/2021 13:13 448,084 u-boot.elf
5 File(s) 1,444,538 bytes
4 Dir(s) 422,109,966,336 bytes free
xsdb% xmd source -tcl run.tcl

****** Xilinx Microprocessor Debugger (XMD) EngineExecuting user script : run.tcl

JTAG chain configuration
--------------------------------------------------
Device ID Code IR Length Part Name
1 4ba00477 4 arm_dap
2 13722093 6 xc7z010

--------------------------------------------------
Enabling extended memory access checks for Zynq.
Writes to reserved memory are not permitted and reads return 0.
To disable this feature, run "debugconfig -memory_access_check disable".

--------------------------------------------------

CortexA9 Processor Configuration
-------------------------------------
Version.............................0x00000003
User ID.............................0x00000000
No of PC Breakpoints................6
No of Addr/Data Watchpoints.........4

Connected to "arm" target. id = 64
Starting GDB server for "arm" target (id = 64) at TCP port no 1234
Processor stopped

Error Executing User Script : run.tcl
Error :: ERROR: No Elf file associated with target

****** XMD v2014.1 (64-bit)
**** SW Build 881834 on Fri Apr 4 14:06:19 MDT 2014
** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.

xsdb%


@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@


I link to the bootstrap zip file from AD that I am using, I suspect, but what do I know, that I need to somehow associate the u-boot.elf file with the Pluto, but at this point I'm stuck. Any help would be most appreciated. OS is Windows 10 64 bit Pro and I have tried using Xilinx SDK 2014.1 and Vivado Lab 2017.3

Current versions of Xilinx fail to load at all on this PC, the installer fails to complete, but AD tell me I need a legacy version anyway, that supports XMD as that is what they based the run.tcl format on.

The JTAG bootstrap files are here :

http://www.chriswilson.tv/plutosdr-jtag-bootstrap-v0.34(1).zip

Thanks for any insight!



--


Best regards,
 Chris                            mailto:chris@...







Is anyone familiar with Xilinx Vivado software to JTAG a PlutoSDR??

Chris Wilson
 

13 June 2022


I have a totally bricked Pluto SDR that dfu-util fails to see. I am looking for someone familiar with this obtuse software from Xilinx to resurrect it via JTAG. I have the adepter board from Analog Devices and the Digilent board and cable.

If anyone wants the full version please see below, it seems few people have used the JTAG access and documented it well. Here's hoping someone here knows what I have done wrong...


I have bricked my Pluto and Analog Devices seem sure that by using JTAG it can be resurrected. However, using all the free time I can possibly spare I have hit a brick(ed) wall. I am in desperate need of someone who understands this sort of thing and Google searching brings up your good self as obviously extraordinarily knowledgeable on the under bonnet workings of the Pluto.

If you have time and inclination to read the below, this is where I find myself:

Analog Devices dfu-util does not see it, and it's now in a state where just one LED is lit, and it's very dim.

An Analog Devices tech help forum suggestion (by an AD engineer) was that the only fix was using JTAG and I would need both the interface box from AD and a cable and dongle from Digilent (sp?).

I purchased those and followed the instructions here after going through hoops to find and download a legacy version of Xilnx programming software that still supported the XMD Console.

https://wiki.analog.com/university/tools/pluto/devs/fpga

This stuff sees my Pluto and will communicate with it but I am now stuck at where I am below.

I have come back to this after getting a headache and getting nowhere in the last week ;)


I am finding on Google others have issues with forcing a target, but maybe I am way off course. Below I copy paste the results of trying to run the run.tcl file AD supply in a zip with other files. I set the Xilinx workspace to C:/workspace and unzipped the supplied files in there, and before trying to run the run.tcl I ensured I was in the workspace directory. Does this give a clues as to what's gone wrong please? Even when the none running core is running the same happens. To get it running I have to power down the PlutoSDR and power it up again.

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

****** Xilinx System Debugger (XSDB) v2014.1
**** Build date : Apr 4 2014-14:07:09
** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.


Got $XILINX_SDK: C:/XilinxSDK/SDK/2014.1

xsdb% connect -host localhost -port 3121 tcfchan#0
::tcfchan#0
xsdb% targets
1 xc7z010
2 APU
3 ARM Cortex-A9 MPCore #0 (Stopped: Suspended)
4 ARM Cortex-A9 MPCore #1 (Running)
xsdb% target 1
xsdb% targets
1* xc7z010
2 APU
3 ARM Cortex-A9 MPCore #0 (Stopped: Suspended)
4 ARM Cortex-A9 MPCore #1 (Running)
xsdb% cd C:/workspace
xsdb% dir
Volume in drive C has no label.
Volume Serial Number is D080-C2AD

Directory of C:\workspace

11/06/2022 09:50 <DIR> .
11/06/2022 09:50 <DIR> ..
10/06/2022 10:31 <DIR> .metadata
20/08/2021 13:12 31,486 ps7_init.tcl
10/06/2022 12:28 <DIR> RemoteSystemsTempFiles
03/03/2017 08:56 257 run.tcl
11/06/2022 10:11 567 SDK.log
20/08/2021 13:12 964,144 system_top.bit
20/08/2021 13:13 448,084 u-boot.elf
5 File(s) 1,444,538 bytes
4 Dir(s) 422,109,966,336 bytes free
xsdb% xmd source -tcl run.tcl

****** Xilinx Microprocessor Debugger (XMD) EngineExecuting user script : run.tcl

JTAG chain configuration
--------------------------------------------------
Device ID Code IR Length Part Name
1 4ba00477 4 arm_dap
2 13722093 6 xc7z010

--------------------------------------------------
Enabling extended memory access checks for Zynq.
Writes to reserved memory are not permitted and reads return 0.
To disable this feature, run "debugconfig -memory_access_check disable".

--------------------------------------------------

CortexA9 Processor Configuration
-------------------------------------
Version.............................0x00000003
User ID.............................0x00000000
No of PC Breakpoints................6
No of Addr/Data Watchpoints.........4

Connected to "arm" target. id = 64
Starting GDB server for "arm" target (id = 64) at TCP port no 1234
Processor stopped

Error Executing User Script : run.tcl
Error :: ERROR: No Elf file associated with target

****** XMD v2014.1 (64-bit)
**** SW Build 881834 on Fri Apr 4 14:06:19 MDT 2014
** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.

xsdb%


@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@


I link to the bootstrap zip file from AD that I am using, I suspect, but what do I know, that I need to somehow associate the u-boot.elf file with the Pluto, but at this point I'm stuck. Any help would be most appreciated. OS is Windows 10 64 bit Pro and I have tried using Xilinx SDK 2014.1 and Vivado Lab 2017.3

Current versions of Xilinx fail to load at all on this PC, the installer fails to complete, but AD tell me I need a legacy version anyway, that supports XMD as that is what they based the run.tcl format on.

The JTAG bootstrap files are here :

http://www.chriswilson.tv/plutosdr-jtag-bootstrap-v0.34(1).zip

Thanks for any insight!



--


Best regards,
Chris mailto:chris@...


Re: Anyone know this SDR

Larry Dodd
 

I believe the clone SDR in question uses the Mirics MSi3101 chipset same as used in SDRplay receivers. I would “guess” the four switches have something to do with its AM demodulator. “Perhaps“ they set AM bandwidths? If you can power it up “I’d“ experiment with the switches to see/hear their effects. I have one on order waiting delivery. 
Larry K4LED 

_______________________

On Jun 12, 2022, at 9:35 AM, Simon Brown <simon@...> wrote:


Mike,

I just read this - didn't realise you're GD6ICR (I was GD8IQM then GD4ELI until I left the rock for work post-university). 

If you're interested, I have an as-new RSP1A in original packing, will sell to you for 50% of the new price (whatever that is). It was used in my USA office for a project, did its job and is now on the shelf in my computer room.

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on behalf of Mike via groups.io <gd6icr@...>
Sent: 11 June 2022 18:19
To: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io>
Subject: [SDR-Radio] Anyone know this SDR
 
Need to know the switch settings on this SDR please

--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Re: Anyone know this SDR

Simon Brown
 

Mike,

I just read this - didn't realise you're GD6ICR (I was GD8IQM then GD4ELI until I left the rock for work post-university). 

If you're interested, I have an as-new RSP1A in original packing, will sell to you for 50% of the new price (whatever that is). It was used in my USA office for a project, did its job and is now on the shelf in my computer room.

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> on behalf of Mike via groups.io <gd6icr@...>
Sent: 11 June 2022 18:19
To: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io>
Subject: [SDR-Radio] Anyone know this SDR
 
Need to know the switch settings on this SDR please

--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.


Re: Anyone know this SDR

Jon Hudson
 

In the USA, HRO is the authorized reseller of the RSP1A: https://www.hamradio.com/detail.cfm?pid=H0-015965
 
Nooelec,  Airspy and SDRplay have all suffered from copycats and scam sellers. More about SDRplay fakes here: https://www.sdrplay.com/fakealert/

RSP1 driver software is the intellectual property of SDRplay and are not licensed for use with hardware pretending to be SDRplay hardware.

Best regards,  Jon, SDRplay


Re: Anyone know this SDR

biscegliem
 

here there is another picture, you can zoom on it to see better the two switch boards

Il 11.06.2022 19:19 Mike ha scritto:

Need to know the switch settings on this SDR please



Voucher MISE per P.IVA e PMI: fino a 2500€ per la Banda Ultralarga. https://casa.tiscali.it/promo/?u=https://promozioni.tiscali.it/voucher_business/


Re: Anyone know this SDR

biscegliem
 

Hello to the group, this is a sdr clone of RSP1 , it works installing drivers of sdrplay rsp1. There are two versions, this have dip switches to select the proper input filter, the other one havve 5 sma input connectors. for the various bands. I bought a pair on aliexpress and it works fine with sdr-uno and sdr-radio software. About the dip-sw  use the so called AM-SW1 on the board, to select  0-12 or 12-30 for the shortwaves, then on the  SW-2 select the #8 or #7 , I hope to be clear ... Sorry for my english :-)

Il 11.06.2022 19:19 Mike ha scritto:

Need to know the switch settings on this SDR please



Voucher MISE per P.IVA e PMI: fino a 2500€ per la Banda Ultralarga. https://casa.tiscali.it/promo/?u=https://promozioni.tiscali.it/voucher_business/


Re: Anyone know this SDR

George Smythe
 

Thanks John ...

Used it to find the following:

Original:  https://www.sdrplay.com/rsp1/ (now discontinued)
Upgrade:   https://www.sdrplay.com/rsp1A/ ($117+VAT+$22.78 Courier Shipping


George [KB2GSM]



On Sat, Jun 11, 2022 at 4:27 PM John N5XJL <qra.n5xjl@...> wrote:
Hello, Mike.

This is being sold by numerous dealers on eBay. If you search for this phrase, you'll find lots of listings: "RSP1 Msi2500 Msi001 Scheme Radios Reciver 10kHz-2GHz 12Bit ADC Radios Receiving"

I didn't see any documentation on the first couple of listings I checked out, but maybe that'll be enough information to get you on the trail of something.

John



--
GSM -> George W. Smythe
+1 (631) 780-4476
jethawk@...
------------------------------------------------


Re: Anyone know this SDR

N2MS
 

Zooming in on the pictures it looks like the dip switches set the frequency range and range filters.

Anyone know which software supports this board?

Mike N2MS

On 06/11/2022 3:29 PM John N5XJL <qra.n5xjl@...> wrote:


Hello, Mike.

This is being sold by numerous dealers on eBay. If you search for this phrase, you'll find lots of listings: "RSP1 Msi2500 Msi001 Scheme Radios Reciver 10kHz-2GHz 12Bit ADC Radios Receiving"

I didn't see any documentation on the first couple of listings I checked out, but maybe that'll be enough information to get you on the trail of something.

John

2201 - 2220 of 68710