Re: For Simon, From Bob


Simon Brown
 

Bob,

 

I want you to run DebugView https://www.sdr-radio.com/diagnostics#DebugView :

 

  • Download, install, start.
  • Start Console, connect to the R8600.
  • Change frequency a few times with Console.
  • In DebugView, File menu save the output to a file and send to me direct: simon@...
  • The file will have a lot of interesting diagnostic information.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of rmrrgs
Sent: 14 March 2022 19:41
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] For Simon, From Bob

 

Hi,

Yes, I tried a different cable and Port.  And a higher bandwidth.

Am using the Icom Driver; wondering if I should try yours instead ?

Will be most interested to see how you make out with your radio, and with the Icom Driver.
Won't do anything more until then.

My guess is that, as usual, I'm missing something very simple.
But, Console does communicate, and work with the radio, but has the "anomalies" I've mentioned.

Will recopy what I wrote previously, as there might be some good info in it.

Again, thanks so much for help and interest,

Bob
----------------------------------------------------
Radio USB cable goes from radio IQ  Port to pc.  No Hub in use.

I have installed, per your writeup, the ICOM download “USB I/Q Package for HDSDR”.

Hopefully correctly ?  Not sure.  It was the X64 version.

It installed, apparently, into HDSDR.

*Should it (also) be installed into a SDRConsole Folder ?  The Installer wouldn’t allow any options.

        *Located it in Device Mgr. /Universal Serial Bus Devices. 

        Shows there as: IC-R8600 I/Q Out Port (WinUSB)

       **Is this correct ?  Any other places it should be, or anything else related to this

         Driver that I should do ?

 Tried using HDSDR with the R8600 as an experiment.

 The LO numbers when tuned in HDSDR, change the R8600 frequency perfectly.

The Tune numbers do not effect the numbers showing in the R8600.

 The mode buttons in HDSDR do not change the mode in the R8600

          The R8600 seems to stay locked on USB, as with Console.

 Back to Console:

 Looking at the Console Definitions, I see for the R8600 in “Select Radio/Options” :

               \\?\usb#vid_0c268&pid_ …….   (note the “usb”)  Is this correct ?
                                                                  Would this "lock" the Mode Select buttons ?

 I select the 8600 in Console, and say START;

 Console does seem to communicate with the R8600.

 Changing the tune numbers in Console changes the numbers in

the small panel that appears in the waterfall for Freq. and Span.

Freq: reflects exactly what is shown in the R8600 panel


But changing numbers in Console, sometimes, but not all the time,

doesn’t always change exactly what the radio shows. 

Usually, only the highest one or two digits change.

Again, what the radio shows always mimics the small panel in the waterfall for Freq.

 
Probably important, and likely a good hint to what is happening:

    *Dragging the small vertical yellow line on the waterfall bottom scale is reflected

     exactly on the radio and also on the small Freq/Scan panel in the Waterfall.

 Mode selection buttons (still) can’t get to work.

 

I keep wondering if there is some configuration in the radio itself that I

haven’t configured correctly. Wouldn’t surprise me that the problem may be here, but

no idea what it might be, if so.


--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.

Join main@SDR-Radio.groups.io to automatically receive all group messages.