Re: RSPdx with SDRPlay 1.41 beta code #sdrplay #sdruno


Simon Brown
 

And,

 

As far as I can tell, the documentation for the 3.08 API is not yet available, so I can’t even start on tentative support. When all is published it’ll only take a day or so.

 

Simon Brown, G4ELI

https://www.sdr-radio.com

 

From: main@SDR-Radio.groups.io <main@SDR-Radio.groups.io> On Behalf Of Barney Breet
Sent: 14 August 2021 18:05
To: main@SDR-Radio.groups.io
Subject: Re: [SDR-Radio] RSPdx with SDRPlay 1.41 beta code #sdrplay #sdruno

 

Hi,

Install SDRUno 1.42, works fine then with SDR Console 3.1 - 64bit.

Regards,

Barney - M1ABV

On 14/08/2021 15:16, John Freeman wrote:

Hi All,

I have been running my RSPdx with SDR Console 3.1 with no problem, after installing SDRUno 1.40, API 3.07,  and creating the definition by searching SDRPlay V3.   

Now when I install SDRUno 1.41 beta, with its new API 3.08, the instruction is to use V2 for now as the new code, I assume API 3.08, is not compatible with SDR Console V3 yet.   However, when I search to create a new definition using SDRPlay V2, my RSPdx is detected, but it comes up as an SDRDuo and the controls in SDR Console are wrong.   If I search using V3, the RSPdx is detected, but the radio will not start.

I reinstalled SDRUno 1.40 and everything works as it did again with the V3 definition, but I find that a search using V2 also results in an SDRDuo definition, so this is not directly related to the SDRUno 1.41 beta.  

I have reinstalled SDR Console, but the problem still occurs.   The info in the definition screen (attached) implies that the dll being used is for 2.13 which does not support RSPdx?    Do I have the wrong dll somehow?   Any other ideas or things to check?   



Thanks,
John


--
- + - + -
Please use https://forum.sdr-radio.com:4499/ when posting questions or problems.

Join main@SDR-Radio.groups.io to automatically receive all group messages.